Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Null MessageBroker in lcds samples?

Avatar

Level 1

Forgive me but I'm having issues getting the LCDS samples to run under Tomcat 6.0.  I've deployed all 3 war files included in the download (ds-console.war, lcds.war, and lcds-samples.war) and none of the sample apps seem to work.  It looks like the result of the call to MessageBroker.getMessageBroker(null); is always null, causing null pointer exceptions.  I've been able to install and run the BlazeDS samples without error.  Is there something special I need to do to get the LCDS ones running?

1 Accepted Solution

Avatar

Correct answer by
Employee

Hi Steve,

Looking at some of the errors it seems you are missing jta.jar. Can you put the logs in a ftp location I can access?

I suggest you first try using the Tomcat turnkey installation that is delivered with the LCDS installation and see if it gets you working. If yes, then I suggest you copy the missing jars into your tomcat distro. The jars are part of your webapp as well as those that are part of tomcat lib directory.

Hope that helps.

Rohit

View solution in original post

4 Replies

Avatar

Level 2

Hi !

If you could send the server log,i can help you what's happening .

Avatar

Level 1

Hi Chandra - I appreciate your help. The BlazeDS samples worked without any problems for me, but for some reason their LCDS equivalents aren't working. Basically what I've done is download and extract lcds, then:

1. Start the sampledb in the lcds/sampledb directory

2. Start Tomcat

3. Deploy the 3 war files included in the LCDS distro

4. Navigate to http://localhost:8082/lcds-samples/testdrive.htm and attempt to run the "startfeed.jsp" in the data push example. This results in an immediate NullPointerException on line 56 of Feed.java because msgBroker is null:

msgBroker.routeMessageToService(msg, null);

I looked in the server logs and didn't see anything that gave me any clues. There are a bunch of Hibernate exceptions that are being thrown when I deploy the wars, but I didn't think that would have anything to do with it...

I appreciate any help you can give

Avatar

Correct answer by
Employee

Hi Steve,

Looking at some of the errors it seems you are missing jta.jar. Can you put the logs in a ftp location I can access?

I suggest you first try using the Tomcat turnkey installation that is delivered with the LCDS installation and see if it gets you working. If yes, then I suggest you copy the missing jars into your tomcat distro. The jars are part of your webapp as well as those that are part of tomcat lib directory.

Hope that helps.

Rohit

Avatar

Level 1

Rohit, thanks again for all of your help.  That did the trick.  The turnkey installation actually performed the same way as my local Tomcat install - didn't work.  So I downloaded jta.jar and copied it into the web-inf/lib directory of the samples webapp in Tomcat and magically everything worked.

Thanks for your help on this, and also on my other issues!