Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

NetConnection.Call.Failed

Avatar

Avatar
Level 1
adam704a
Level 1

Likes

0 likes

Total Posts

4 posts

Correct Reply

0 solutions
View profile

Avatar
Level 1
adam704a
Level 1

Likes

0 likes

Total Posts

4 posts

Correct Reply

0 solutions
View profile
adam704a
Level 1

19-01-2009

I am running this on Tomcat 6.0.16 with the latest BlazeDS
jars (3.2.0.3978). I have spent quite a while on this and am not
getting anywhere. I verified the configuration but I am still
getting this error:



RPC Fault faultString="Send failed"
faultCode="Client.Error.MessageSend"
faultDetail="Channel.Connect.Failed error
NetConnection.Call.Failed: HTTP: Failed: url: '
http://localhost:8080/WebContent/messagebroker/amf'"

at mx.rpc::AbstractInvoker/
http://www.adobe.com/2006/flex/mx/internal::faultHandler()[C:\autobuild\3.2.0\frameworks\projects\rp...

at
mx.rpc::Responder/fault()[C:\autobuild\3.2.0\frameworks\projects\rpc\src\mx\rpc\Responder.as:53]

at
mx.rpc::AsyncRequest/fault()[C:\autobuild\3.2.0\frameworks\projects\rpc\src\mx\rpc\AsyncRequest.as:103]

at
mx.messaging::ChannelSet/faultPendingSends()[C:\autobuild\3.2.0\frameworks\projects\rpc\src\mx\messaging\ChannelSet.as:1482]

at
mx.messaging::ChannelSet/channelFaultHandler()[C:\autobuild\3.2.0\frameworks\projects\rpc\src\mx\messaging\ChannelSet.as:975]

at flash.events::EventDispatcher/dispatchEventFunction()

at flash.events::EventDispatcher/dispatchEvent()

at
mx.messaging::Channel/connectFailed()[C:\autobuild\3.2.0\frameworks\projects\rpc\src\mx\messaging\Channel.as:997]

at
mx.messaging.channels::PollingChannel/connectFailed()[C:\autobuild\3.2.0\frameworks\projects\rpc\src\mx\messaging\channels\PollingChannel.as:354]

at
mx.messaging.channels::AMFChannel/statusHandler()[C:\autobuild\3.2.0\frameworks\projects\rpc\src\mx\messaging\channels\AMFChannel.as:390]



Notes:

- I turned the logging up to debugging in the
services-config.xml which printed out this in the system console



[BlazeDS]01/20/2009 00:18:11.430 [INFO] [Configuration]
BlazeDS - Community Edition: 3.2.0.3978

[BlazeDS]01/20/2009 00:18:11.504 [INFO] [Configuration]
Endpoint my-amf created with security: None

at URL:
http://{server.name}:{server.port}/{context.root}/messagebroker/amf

[BlazeDS]01/20/2009 00:18:11.510 [INFO] [Configuration]
Endpoint my-polling-amf created with security: None

at URL:
http://{server.name}:{server.port}/{context.root}/messagebroker/amfpolling

[BlazeDS]01/20/2009 00:18:11.510 [INFO] [Configuration]
Endpoint my-secure-amf created with security: None

at URL:
https://{server.name}:{server.port}/{context.root}/messagebroker/amfsecure

[BlazeDS]01/20/2009 00:18:11.633 [DEBUG] [Configuration]
MessageBroker id: __default__ classLoader is: the MessageBroker's
class loader and the context class loader (classLoader hashCode:
15288634 (parent hashCode: 15805518 (parent system))



- Download my code here:
http://www.adampreston.com/code/TestFlex.zip

Accepted Solutions (0)

Answers (7)

Answers (7)

Avatar

Avatar
Level 1
chandanpandey05
Level 1

Likes

0 likes

Total Posts

1 post

Correct Reply

0 solutions
View profile

Avatar
Level 1
chandanpandey05
Level 1

Likes

0 likes

Total Posts

1 post

Correct Reply

0 solutions
View profile
chandanpandey05
Level 1

23-08-2011

I ran into same issue and although serverContextRoot was pointing to correct context .. follwoign was issue
--By  default  <servlet-class>flex.messaging.MessageBrokerServlet<\servlet-clas\>  is declared with <\load-on-startup\>1<\/load-on-startup\>.
In  my case i had changed  <\load-on-startup\>1<\/load-on-startup\> to some other  servlet ..and ran in this issue ..Conclusion  <\load-on-startup\>1<\/load-on-startup\> MUST be used with  <\servlet-class\>flex.messaging.MessageBrokerServlet<\/servlet-class\>   It's NOT OPTIONAL

Avatar

Avatar
Level 1
NoSilverBullet
Level 1

Likes

0 likes

Total Posts

3 posts

Correct Reply

0 solutions
View profile

Avatar
Level 1
NoSilverBullet
Level 1

Likes

0 likes

Total Posts

3 posts

Correct Reply

0 solutions
View profile
NoSilverBullet
Level 1

05-11-2010

Avatar

Avatar
Level 1
samiob
Level 1

Likes

0 likes

Total Posts

1 post

Correct Reply

0 solutions
View profile

Avatar
Level 1
samiob
Level 1

Likes

0 likes

Total Posts

1 post

Correct Reply

0 solutions
View profile
samiob
Level 1

14-07-2010

I have searched everywhere in the net to resolve this problem and finally i found the solution , of course it appear so easy like always, all what you have to do is to replace the context root in the properties of the flex project with the name of the project (/flex_name_project), normally you will find "/Webcontent", u have to replace it with the new one, and it's done

hope that will help you

@+

Avatar

Avatar
Level 1
eduardocor
Level 1

Likes

0 likes

Total Posts

1 post

Correct Reply

0 solutions
View profile

Avatar
Level 1
eduardocor
Level 1

Likes

0 likes

Total Posts

1 post

Correct Reply

0 solutions
View profile
eduardocor
Level 1

02-07-2010

I not solved this. This is the code that comes with BlazeDS. Someone would have any other suggestions?

Avatar

Avatar
Level 1
Ghe1982
Level 1

Likes

0 likes

Total Posts

2 posts

Correct Reply

0 solutions
View profile

Avatar
Level 1
Ghe1982
Level 1

Likes

0 likes

Total Posts

2 posts

Correct Reply

0 solutions
View profile
Ghe1982
Level 1

05-05-2009

I solved adding this:

    <!-- MessageBroker Servlet -->

    <servlet>

        <servlet-name>MessageBrokerServlet</servlet-name>

        <display-name>MessageBrokerServlet</display-name>

        <servlet-class>flex.messaging.MessageBrokerServlet</servlet-class>

        <init-param>

            <param-name>services.configuration.file</param-name>

            <param-value>/WEB-INF/flex/services-config.xml</param-value>

        </init-param>

        <load-on-startup>1</load-on-startup>

    </servlet>

    <servlet-mapping>

        <servlet-name>MessageBrokerServlet</servlet-name>

        <url-pattern>/messagebroker/*</url-pattern>

    </servlet-mapping>

to my web.xml file.

Avatar

Avatar
Level 1
Ghe1982
Level 1

Likes

0 likes

Total Posts

2 posts

Correct Reply

0 solutions
View profile

Avatar
Level 1
Ghe1982
Level 1

Likes

0 likes

Total Posts

2 posts

Correct Reply

0 solutions
View profile
Ghe1982
Level 1

05-05-2009

Hi,

I am having the same issue you had (http://forums.adobe.com/message/1940284#1940284), can you help me solving it ?

Thanks.

Avatar

Avatar
Level 1
adam704a
Level 1

Likes

0 likes

Total Posts

4 posts

Correct Reply

0 solutions
View profile

Avatar
Level 1
adam704a
Level 1

Likes

0 likes

Total Posts

4 posts

Correct Reply

0 solutions
View profile
adam704a
Level 1

20-01-2009

Nevermind, I got it. I didn’t set my context in the
Flex project properties -> Server Properties