Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

MSSQL JDBC Driver 2.0 and 3.0 with LiveCycle ES 2.5 (ES2 SP2, 9.0.0.2,9.5,etc.)

Avatar

Level 1

The documentation for LiveCycle ES2.5 still indicates that the JDBC driver for MSSQL must be version 1.2. This version is no longer available for download from Microsoft. They only offer 2.x and 3.x on the download site. Are there issues with 2.x and 3.x compatibility with LiveCycle installations?

3 Replies

Avatar

Employee

Adobe LiveCycle Installer dumps the supported drivers in install directory. Hence, you need not download it from Microsoft site. LiveCycle 9.0.0.2 was certified with 1.2. However, LiveCycle has a process called Customer Certification Request (CCR) process whereby platforms not earlier certified can also be certified on request if feasibility exists. You may contact Adobe to check if LC can assess your requirement and perform certification for your platform, components and the driver version. All customers can reach out to Account managers for such a request.

Avatar

Level 1

Thanks for the note. I did find the locally installed resource. I would suggest that it be QA'ed as part of the next service pack / product release though. The older driver has been discontinued and LC documentation does say to "download the 1.2 driver". It does not refer to the local CD resource directories.

Avatar

Employee

Hi Anthony

You should be able to find the recommended driver at C:\Adobe\LiveCycle\lib\db\mssql folder. .

For next product release, we have already moved to higher version of driver - MS JDBC 3.0 sqljdbc4.jar.

For support on older release, CCR process as I explained in my earlier note, is needed.

Hope that helps!