Malformed SOM expression: form1[0]ConcreteFieldReport[0].FooterFields[0].SignatureField1[0]

Avatar

Avatar

justtester96

Avatar

justtester96

justtester96

06-07-2015

!I have created several PDF Forms for our technicians at our company using LiveCycle Designer. For some reason, when our administrative personnel open some of the files, they get the error above.

This is critical for our business. Can someone please help?

Lily-Issue.PNG

Accepted Solutions (0)

Answers (9)

Answers (9)

Avatar

Avatar

radzmar

MVP

Total Posts

2.6K

Likes

386

Correct Answer

485

Avatar

radzmar

MVP

Total Posts

2.6K

Likes

386

Correct Answer

485
radzmar
MVP

06-07-2015

Add the missing dot.


xfa.resolveNode("form1[0].ConcreteFieldReport[0].FooterFields[0].SignatureField1[0]").rawValue = "something";


Avatar

Avatar

jasotastic81

Avatar

jasotastic81

jasotastic81

06-07-2015

Is there a dot missing between the first index and Concrete?

form1[0].ConcreteFieldReport[0].FooterFields[0].SignatureField1[0]

Avatar

Avatar

jasotastic81

Avatar

jasotastic81

jasotastic81

07-07-2015

Open the form in LC, select form1 in the hierarchy, open the script window if it isn't already open (Window > Script Editor), change the view to show "Events with Scripts", press CTRL+F to open the find box, and type the expression in the "Find What" field. You'll probably have to leave out the indexes, and you'll likely only need the first part of it.

Avatar

Avatar

justtester96

Avatar

justtester96

justtester96

07-07-2015

But how do I find the script?

Avatar

Avatar

jasotastic81

Avatar

jasotastic81

jasotastic81

07-07-2015

You'll have to find the script that has the incorrect string and put it in.

Avatar

Avatar

justtester96

Avatar

justtester96

justtester96

07-07-2015

How do I add that dot?

Avatar

Avatar

justtester96

Avatar

justtester96

justtester96

06-07-2015

So what should I do to eliminate this problem?

Avatar

Avatar

jasotastic81

Avatar

jasotastic81

jasotastic81

06-07-2015

This is the only way I can get that error in Acrobat. Notice that I left the dot out of the string between form1[0] and ConcreteFieldReport[0].

786067_pastedImage_0.png

786071_pastedImage_1.png

Avatar

Avatar

justtester96

Avatar

justtester96

justtester96

06-07-2015

No, there is no dot missing