Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Locale does not work with WordNum()

Avatar

Level 5

I have this form with a field that should be filled in with text corresponding to a value field, automatically.

So I got this:

form1.#subform[0].extenso::calculate - (FormCalc, client)

textNumber = WordNum(total,0,"pt_BR");

...and nothing happens, the values are being converted into English text, not Portuguese.

Where is the catch?

I also changed the PDF default locale in Designer to Portuguese Brazilian. Still doesn't work.

Please, help!

Marcos

1 Accepted Solution

Avatar

Correct answer by
Level 10

Looks like it is English only - just noticed a note in the docs that says "as of this release, it is not possible to specify a locale identifier other than English for this function."

The version of the doc I have is for 8.1 so it may still be true depending on which version you're using.

So looks like you may be better off with JavaScript, you can probably find a sample on the web that's already in Portuguese instead of trying to map English->Portuguese.

View solution in original post

0 Replies

Avatar

Correct answer by
Level 10

Looks like it is English only - just noticed a note in the docs that says "as of this release, it is not possible to specify a locale identifier other than English for this function."

The version of the doc I have is for 8.1 so it may still be true depending on which version you're using.

So looks like you may be better off with JavaScript, you can probably find a sample on the web that's already in Portuguese instead of trying to map English->Portuguese.