Livecycle Image field upload issue with .tiff/.tif format

Radhika_Magaji

29-04-2015

Hello,

I have a requirement to implement image upload in pdf form which im doing with a help of "Image Field" object. I understand for uploading the image we need form to be reader extended(via Adobe Acrobat Pro or LiveCylce Rights Managament).

I am also aware the file formats supported are ".jpg, .png, .gif and .tif". However it accepts .jpeg/.tiff  formats as well.

I am facing issues uploading file with .tif/.tiff formats. Below are the steps explaining the issue.

1. Click on the "Image Field" to upload file(.tif/.tiff formats)

2. Browse window opens and I select file with tif/.tiff format.

3. Image is successfuly uploaded.

4. Now, I decide to replace the image with another tif/.tiff format file.

5. Repeat steps1-2

6. Upon selecting a new image, I still have the first image that was uploaded earlier in my image field.

Step 6 is not what is expected.

I have "Embed image data" selected within designer and have not specified any URL. Is there any known issue regarding .tif/.tiff file formats in LiveCycle? There seems no issue with other file formats. I am using LiveCycle Designer 10.

I also learnt the below from adobe help forums on TIF image format-

"Tagged Image File (TIF)

Designer supports Monochrome (1 color component 1-bit depth), Greyscale (1 color component 8-bit depth), RGB (3 color components 8-bit depth), and Palette (1 color component 1,2,4,8-bit depths) TIF images.

An initial (default) image to insert at run time can be specified by either a file name or a Uniform Resource Locator (URL). Initially, the image is linked, which means that it is stored separately from the form and displayed when the form is opened. Alternatively, the image data can be embedded in the form when the form is created."

Any help would be highly appreciated.

Thanks,

Radhika

View Entire Topic

Radhika_Magaji

07-05-2015

Yes the code works perfectly fine for me.

The issue is just the .tiff/.tif upload! Could you please re-create these steps and check ?

I am facing issues uploading file with .tif/.tiff formats. Below are the steps explaining the issue.

1. Click on the "Image Field" to upload file(.tif/.tiff formats)

2. Browse window opens and I select file with tif/.tiff format.

3. Image is successfuly uploaded.

4. Now, I decide to replace the image with another tif/.tiff format file.

5. Repeat steps1-2

6. Upon selecting a new image, I still have the first image that was uploaded earlier in my image field.

Step 6 is not what is expected.

I don know if this is a known issue. This happens in any new form i create and upload .tiff/.tif format image.