Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Livecycle ES4 could not access CQ welcome page

Avatar

Level 1


 

I have installed Livecycle ES4 on Linux following the install guide provided. I was at the step of verifying Post-deployment tasks. All the following web browser URL worked except URL below. 

 

5.1.3.3  Accessing CQ Welcome Page  - [http://[hostname]:[port]:/lc/welcome | http://[hostname]:[port]:/lc/welcome]

 

5.1.3.5  Change CQ Administrator default password - http://....../lc/libs/granite/security/content/admin.html

 

5.2.3 Access HTML Workspace - http://...../lc/ws

 

5.2.4 Access Forms Manager - http://..../lc/fm

 

I got the following message on error.log

 

org.apache.sling.engine.impl.SlingHttpContext handlesSecurity: AuthenticationSupport service missing. Cannot authenticate request.

 

org.apache.sling.engine.impl.SlingHttpdContext handleSecurity: Possible reason is missing Repository service. Check AuthenticationSupport dependencies.

 

And web browser URL not working above all gave out the error text message:-

 

AuthenticationSupport service missing. Cannot authenticate request.  


 

0 Replies

Avatar

Level 1

Hi,

Have you selected the Forms Manager,Process Management and Content Repository on Module Selection screen and configured through LiveCycle Configuration Manager? As these URL's are only available if you have selected and configured the above components.

Thanks,

Shishir

Avatar

Level 1

Shishir, I have selected all modules. I installed Livecycle on Linux Red Hat and Acrobat is not available on Linux (only on Windows and Mac). I used OpenOffice as PDF software instead. When installing Livecycle through Configuration Manager GUI, the section Configure Acrobat for PDF Generator did not appeared. All section install completed successful including software check list in the last part. I can access URL web browser http:// ...../launchpad to install and use OpenOffice PDF software on my Windows desktop. Thank you.

Avatar

Level 1

Yes i can. All bundles are started active and there are some bundles identified "Fragment".  There is no "Start" option - only "Refresh Package Imports" and "Update" available which I tried to click on and it said "Operation completed successfully". But the bundles stayed "Fragment".  There are 1304 components available under status "Active" , "Unsatisfied","Registered" and "Factory".  I suspect component "com.day.cq.wcm.foundation.impl.HTTPAuthHandler" may be the issue. It is under status "Disabled" and when i clicked enable it change status to "Unsatisfied".  I tried access URL browser again but still get the same error message.

Avatar

Employee

Do you see any bundles in resolved or installed state?

What did you get in error.log when you tried to start the Disabled component?

Avatar

Level 1

No, there are 388 bundles in total - 372 active and 16 active fragments.

The error i got in error.log is below. And i don't have the directory /[Livecycle Home Directory]/org/apache/felix/bundlerepository/RepositoryAdmin indicated in the error message. I have /..../org/apache/commons/cli2 with all the class files.

02.05.2013 11:51:52.470 *ERROR* [Background Update com.adobe.xmp.worker.files.native.fragment.linux (260)] org.apache.slin
g.extensions.threaddump.internal.Activator Uncaught exception in Thread Thread[Background Update com.adobe.xmp.worker.file
s.native.fragment.linux (260),5,Pooled Threads] java.lang.NoClassDefFoundError: org/apache/felix/bundlerepository/Reposito
ryAdmin
at org.apache.felix.webconsole.internal.core.UpdateHelper.updateFromFelixOBR(UpdateHelper.java:125)
at org.apache.felix.webconsole.internal.core.UpdateHelper.doRun(UpdateHelper.java:86)
at org.apache.felix.webconsole.internal.core.BaseUpdateInstallHelper.run(BaseUpdateInstallHelper.java:121)
at java.lang.Thread.run(Thread.java:662)

Avatar

Level 1

I rebooted the Weblogic Managed Server hosting the Livecycle application. This is the error message for error.log

02.05.2013 17:33:29.432 *ERROR* [FelixStartLevel] org.apache.jackrabbit.core.RepositoryImpl failed to start Repository: internal error: failed to read custom node type definitions stored in /nodetypes/custom_nodetypes.xml javax.jcr.RepositoryException: internal error: failed to read custom node type definitions stored in /nodetypes/custom_nodetypes.xml

02.05.2013 17:33:29.441 *ERROR* [FelixStartLevel] org.apache.jackrabbit.core.RepositoryImpl In addition to startup fail, another unexpected problem occurred while shutting down the repository again. java.lang.NullPointerException

02.05.2013 17:33:29.444 *ERROR* [FelixStartLevel] com.day.crx.sling.server [com.day.crx.sling.server.impl.jmx.ManagedRepository] The activate method has thrown an exception (javax.jcr.RepositoryException: internal error: failed to read custom node type definitions stored in /nodetypes/custom_nodetypes.xml) javax.jcr.RepositoryException: internal error: failed to read custom node type definitions stored in /nodetypes/custom_nodetypes.xml

02.05.2013 17:33:29.447 *ERROR* [FelixStartLevel] com.day.crx.sling.server [com.day.crx.sling.server.impl.jmx.ManagedRepository] Failed creating the component instance; see log for reason

02.05.2013 17:33:29.452 *ERROR* [FelixStartLevel] org.apache.aries.jmx.whiteboard.JmxWhiteboardSupport registerMBean: Cannot register MBean service null with MBean servers: Not an instanceof DynamicMBean or not MBean spec compliant standard MBean

02.05.2013 17:33:29.453 *ERROR* [FelixDispatchQueue] com.day.crx.sling.server FrameworkEvent ERROR (org.osgi.framework.ServiceException: Service factory returned null.) org.osgi.framework.ServiceException: Service factory returned null.

02.05.2013 17:33:30.632 *ERROR* [FelixStartLevel] org.apache.jackrabbit.core.RepositoryImpl failed to start Repository: internal error: failed to read custom node type definitions stored in /nodetypes/custom_nodetypes.xml javax.jcr.RepositoryException: internal error: failed to read custom node type definitions stored in /nodetypes/custom_nodetypes.xml

02.05.2013 17:33:30.633 *ERROR* [FelixStartLevel] org.apache.jackrabbit.core.RepositoryImpl In addition to startup fail, another unexpected problem occurred while shutting down the repository again. java.lang.NullPointerException

02.05.2013 17:33:30.633 *ERROR* [FelixStartLevel] com.day.crx.sling.server [com.day.crx.sling.server.impl.jmx.ManagedRepository] The activate method has thrown an exception (javax.jcr.RepositoryException: internal error: failed to read custom node type definitions stored in /nodetypes/custom_nodetypes.xml) javax.jcr.RepositoryException: internal error: failed to read custom node type definitions stored in /nodetypes/custom_nodetypes.xml

02.05.2013 17:33:30.633 *ERROR* [FelixStartLevel] com.day.crx.sling.server [com.day.crx.sling.server.impl.jmx.ManagedRepository] Failed creating the component instance; see log for reason

02.05.2013 17:33:30.633 *ERROR* [FelixDispatchQueue] com.day.crx.sling.server FrameworkEvent ERROR (org.osgi.framework.ServiceException: Service factory returned null.) org.osgi.framework.ServiceException: Service factory returned null.

02.05.2013 17:33:31.727 *INFO* [FelixStartLevel] org.apache.sling.servlets.resolver Service [org.apache.sling.servlets.resolver.internal.defaults.DefaultErrorHandlerServlet,240] ServiceEvent REGISTERED

02.05.2013 17:33:32.913 *ERROR* [FelixStartLevel] com.day.cq.mailer.impl.DefaultMailService invalid configuration: SMTP host must not be blank.

02.05.2013 17:33:32.913 *ERROR* [FelixStartLevel] com.day.cq.mailer.impl.DefaultMailService Invalid mail service configuration.

02.05.2013 17:33:39.171 *ERROR* [FelixDispatchQueue] com.adobe.livecycle.dataservices.dataservices-bundle FrameworkEvent ERROR (java.lang.NullPointerException) java.lang.NullPointerException

02.05.2013 17:33:39.187 *ERROR* [FelixDispatchQueue] com.adobe.livecycle.dataservices.dataservices-bundle FrameworkEvent ERROR (java.lang.NullPointerException) java.lang.NullPointerException

This is the logs from Managed Server output:-

####<May 2, 2013 5:33:39 PM CDT> <Error> <ServletContext-/lc> <srvhouplmtst01> <adobe-server> <SpringOsgiExtenderThread-14> <<anonymous>> <> <8e172a9a8cc8d1be:-6d097724:13e675f49b9:-8000-0000000000000002> <1367534019168> <BEA-000000> <ERROR: EventDispatcher: Error during dispatch. (java.lang.NullPointerException)
####<May 2, 2013 5:33:39 PM CDT> <Error> <ServletContext-/lc> <srvhouplmtst01> <adobe-server> <SpringOsgiExtenderThread-14> <<anonymous>> <> <8e172a9a8cc8d1be:-6d097724:13e675f49b9:-8000-0000000000000002> <1367534019186> <BEA-000000> <ERROR: EventDispatcher: Error during dispatch. (java.lang.NullPointerException)

Weblogic AdminServer and Managed Server are running Active. Livecycle deployment are running Active for "adobe-livecycle-native-weblogic-x86_linux","adobe-livecycle-weblogic" and "adobe-workspace-client". Livecycle installation on Linux Red Hat 5.9 with Oracle JRockit 1.6, Weblogic 10.3.6, Apache OpenOffice 3.4 and Oracle Database 11gR2. Any comment/input are welcome.

Avatar

Level 2

Can you try clean startup using the following instructions ?

1.Stop the weblogic server.

2.Delete all directories under crx-repository directory. By default crx-repository is available under <LiveCycle_Install_Dir>.

3.Copy install folder from <LiveCycle_Install_Dir>/configurationManager/export/crx-quickstart to crx-repository directory.

4.Start the server.

5.Try to login to CQ welcome page.

Avatar

Level 1

Pankaj,  I tried your cleanup step but it did not worked.  I solved the issue by completely deleted crx-repository and re-start the server. Thanks all for the comment.

Avatar

Employee

Removing the directory will mean that some of the product components will not work. If you do not need such components (Mobile Forms and Form Manager), then on module selection screen, you can remove these components along with content repository. That ways CRX will not be installed nor any components which use it