Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

List Box Chosen Value Disappears from XDP as it moves through Process

Avatar

Level 1

I have a List Box that does not remember the value (or values) selected by a user in a task when it moves to the next person in the process. The field becomes blank. Additionally, the data value is not inserted in the FORM XML in the process. I confirmed this via the Process recording of the process in Workbench. Can someone PLEASE help me!?

3 Replies

Avatar

Level 6

What you noticed is how it behaves(normal behavior)....you need to learn work around technique to over come this. I would save the selected value(s) to a hidden field and/or save the value to XML element. And then you need a docReady (or some other event) script to make those values selected each time the form is open/reopen. The same applies to DropDowns too....I do the same for Date fields too some times.

Good Luck,

Avatar

Level 1

Thanks Varma ~ I am not an expert at Scripting. Do you have a sample I can use?

Avatar

Level 6

ok every scripting scenario is different....a sample can give you an idea if you have some knowledge and not helpful when you do not know where to start. More over you did not list your email address to send one and this forum does not allow one to add......Email your copy to n_varma(AT)lycos.com....I will fix it for you and tell you where to look for the code.