Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

Form validation script no longer kicking in

CTA_VO
Level 1
Level 1

Hello,

I maintain a form in which there are some mandatory fields. I've integrated a script in this form that parses that all mandatory fields have been filled in when the form is saved. This script used to run properly, until the last 3 versions of the form when it  doesn't do anything.

I've made no changes to the script, haven't changed computer, but upgraded the LiveCycle Designer to CS3 (version 10.x).

Does anyone have any idea ?

Below is an extract of the script:

PIF.#variables[0].libFunctions - (JavaScript, client)

function ValidationObjet()

{

    var message = "Some mandatory information is missing in fields:"

    if (xfa.form.PIF.PdtCharacteristicsConfigDetails.FrontEnd.FrontEndTable.FrontEnd.Satellite.SatelliteType.rawValue == " Please select")

    {

        message = message + "\n" + " - Satellite"

    }

   

    if (xfa.form.PIF.PdtCharacteristicsConfigDetails.FrontEnd.FrontEndTable.FrontEnd.Cable.CableType.rawValue == " Please select")

    {

        message = message + "\n" + " - Cable"

    }

   

    if (xfa.form.PIF.PdtCharacteristicsConfigDetails.FrontEnd.FrontEndTable.FrontEnd.Terrestrial.TerrestrialType.rawValue == " Please select")

    {

        message = message + "\n" + " - Terrestrial"

    }

if (form.execValidate() == false)

    {

        xfa.host.messageBox(message,"Warning",1,0);

    }  

}

0 Replies