Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Font Embed behaves differently on Client Machines

Avatar

Level 2

All,

What I have done for Font Embedding and what Issue I am facing is explained here.

Steps that I have already done:

  1. I have added the Fonts onto the Server location where the fonts are stored.
  2. Referred this directory to the Client Fonts location through AdminUI.
  3. Changed the value from 0 to 1 in the XCI file under <PDF><fontembed> tag.
  4. Referred the XCI file in my request to FormsServices as below;

         <ser:pdfFormRenderSpec>

              <ser:XCIURI><Path to the Application Folder>/XMLFormService/mySettings.xci</ser:XCIURI>

         </ser:pdfFormRenderSpec>

Now I see the fonts embedded on my PDF on the resultant of FormsServices. (Screenshot attached)

The issue is when I send this PDF to my clients, they dont see the embedded fonts and the PDF looks messy!!!

What might have gone wrong?

scr-Embedd.JPG

Cheers

Mahesh Krishnan

0 Replies

Avatar

Level 3

The font embedding steps seems correct.

When you say "they dont see the embedded fonts", do you mean that there is nothing under 'Fonts' tab when the client opens the PDF?

~ Varun

Avatar

Level 2

They see the default font set to Myriad Pro or something and not the original font that I had set on the PDF.

- MK

Avatar

Level 2

To solve this, I saved my XDP form as Dynamic XML Form and used the same as an Input for FormsService. That solved the issue with Embedding fonts using FormsService.