Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Existing Categories are not listed in the Start Process

Avatar

Level 8

Hello,

I am currently using LC ES3 with SP3 and start having an issue with no Catgory listed in the Workspace ES3.

I checked the AdminUI > Application n Services > Categories and no Category is there either. If I create a new Category in the Admin UI then I can see it is listed in the Workspace ES3 but not sure why all of the existing Categories are not listed there.

Does any one have idea about this issue or any advise on this? Can you please share.

Thanks in advance,

HD

7 Replies

Avatar

Level 8

When yoiu installed the patch did you reinitialize the DB through config manager?  Check the patch installation instructions

Avatar

Level 8

Yes, I did that too. I have restarted the DB as well but it still does not work.

I can see all the category names in the DB or in the Services Management listing of the AdminUI but not in the Category Management. Therefore, they are not shown in the Workspace.

Thanks,

HD

Avatar

Level 1

well this is a known issue and you need to re-deploy missing processes.

http://learn.adobe.com/wiki/display/LCES3RelNotes/Release+Notes+-+LiveCycle+Modules

[Ref # 3152658] -  After performing upgrading from LiveCycle 2.5 or earlier to LiveCycle ES3, some processes may not appear in LiveCycle Workspace. To restore the processes, re-deploy the missing processes.

Avatar

Level 3

I noticed this as well when we upgraded to ES3.  You can also go into the database and modify the category table(TB_SC_CATEGORY) and update the new column(PARENT_OID) with a -1.

Avatar

Level 8

Hi,

Can you explain a little bit more about PARENT_OID and what it means by saying with '-1'.

Thanks, HD

Avatar

Level 3

The -1 simply means it has no parent.  I'm not sure when they enabled trees in the categories(much needed improvement!) as we just upgraded finally from 8.2....  For example if you have Category 1 and Category 2.  If they are both -1 you will see them both on the "Start Process" screen.  Where as if Category 1 was OID(2001) and parent_oid(-1) and Category 2 was OID(2005) and parent_oid(2001) then Category 2 would be under Category 1 in a treeview.

You just need to make sure that the parent_oid column is not nothing.  If you did an upgrade it most likely is like ours was and the column is empty since it was a new column that 8.2 did not have.

Pic1 is (-1) for both.

Pic1.jpg

Pic2 is Category 2 having Category 1 as it's parent.

Pic2.jpg

Pic of the database for With Category 2 using Category 1 as a parent.

pic3.jpg