Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Error when moving to flashOnly\player10.3

Hinne
Level 3
Level 3

I changed compile path from flashOnly\player10.1 to flashOnly\player10.3 and now I get this error:

verify com.adobe.rtc.clientManagers::MicrophoneManager/setAdvancedMicrophone()
                        stack:
                        scope: [global Object$ flash.events::EventDispatcher$ com.adobe.rtc.clientManagers::MicrophoneManager$] ~
                         locals: com.adobe.rtc.clientManagers::MicrophoneManager *
  0:getlocal0
                        stack: com.adobe.rtc.clientManagers::MicrophoneManager
                        scope: [global Object$ flash.events::EventDispatcher$ com.adobe.rtc.clientManagers::MicrophoneManager$] ~
                         locals: com.adobe.rtc.clientManagers::MicrophoneManager *
  1:pushscope
                        stack:
                        scope: [global Object$ flash.events::EventDispatcher$ com.adobe.rtc.clientManagers::MicrophoneManager$] com.adobe.rtc.clientManagers::MicrophoneManager
                         locals: com.adobe.rtc.clientManagers::MicrophoneManager *
  2:pushnull
                        stack: null
                        scope: [global Object$ flash.events::EventDispatcher$ com.adobe.rtc.clientManagers::MicrophoneManager$] com.adobe.rtc.clientManagers::MicrophoneManager
                         locals: com.adobe.rtc.clientManagers::MicrophoneManager *
  3:coerce flash.media::MicrophoneEnhancedOptions
VerifyError: Error #1014: Klasse flash.media::MicrophoneEnhancedOptions wurde nicht gefunden.

    at com.adobe.rtc.clientManagers::MicrophoneManager/get selectedMic()
    at com.adobe.rtc.clientManagers::MicrophoneManager/set micIndex()
    at com.adobe.rtc.clientManagers::MicrophoneManager()
    at com.adobe.rtc.clientManagers::MicrophoneManager$/getInstance()
    at com.adobe.rtc.collaboration::AudioPublisher/get gain()
    at WebCam()
    at SimpleChat/onLogin()
    at flash.events::EventDispatcher/dispatchEventFunction()
    at flash.events::EventDispatcher/dispatchEvent()
    at com.adobe.rtc.session::ConnectSession/checkManagerSync()
    at flash.events::EventDispatcher/dispatchEventFunction()
    at flash.events::EventDispatcher/dispatchEvent()
    at com.adobe.rtc.sharedManagers::UserManager/userReceivedOrEdited()
    at com.adobe.rtc.sharedManagers::UserManager/onItemReceive()
    at flash.events::EventDispatcher/dispatchEventFunction()
    at flash.events::EventDispatcher/dispatchEvent()
    at com.adobe.rtc.sharedModel::CollectionNode/http://www.adobe.com/2006/connect/cocomo/messaging/internal::receiveItem()
    at com.adobe.rtc.messaging.manager::MessageManager/http://www.adobe.com/2006/connect/cocomo/messaging/internal::receiveItem()
    at com.adobe.rtc.session.managers::SessionManagerBase/receiveItem()

0 Replies
nzezelj
Level 4
Level 4

Hi Hinne,

I am not a huge expert in this area, but this looks to me to be very similar to http://forums.adobe.com/thread/889049?tstart=0

Hope it helps,

Nikola

Hinne
Level 3
Level 3

Compiler settings for flash player? How would you do that?

I really cant fix this, can someone help?

sasha_magee
Level 3
Level 3

If you are compiling from the command line, you can add the argument -swf-version=12 to your compiler call

If you are using Flash Builder, you'll need to right click on the project, Choose Properties, and select Flex Compiler. Add -swf-version=12 to the Additional Compiler Arguments text box.

thanks

sasha

Hinne
Level 3
Level 3

no I use flash pro cs5

see: Re: Error when moving to flashOnly\player10.3

sasha_magee
Level 3
Level 3

OK,

Keep in mind that I'm pretty sure authoring for 10.3 is not officially

supported in Flash CS5. However, the following steps seem to work:

1. in your {Flash install}/Common/Configuration/Players folder, you'll see a

FlashPlayer10_2.xml file.

2. Duplicate that file and rename it FlashPlayer10_3.xml

3. Open the new file and change the line starting Publish Settings. There should now be a Player 10.3 item

available in the Player dropdown.

You should now be able to use 10.3-specific APIs. However, I believe you

will not be able to do Test Movie on them, since the built-in player is

10.2-derived. You'll need to publish the file and then test it in a browser.

Thanks

sasha

Hinne
Level 3
Level 3

> authoring for 10.3 is not officially supported in Flash CS5.

does this mean there is no10.3  support for flash inside a web browser?

why is then is there a flashOnly\player10.3 directory in the LCCS Libraries (SWCs) distribution?

sasha_magee
Level 3
Level 3

The Flash CS5 Authoring tool does not support 10.3 officially. However, as I

detailed earlier, with a couple steps you can update the application to

target Flash Player 10.3. Flash playback is of course fully supported.

sasha

Hinne
Level 3
Level 3

Does Flash CS5.5 Authoring tool support 10.3 now?

Hinne
Level 3
Level 3

I just installed cs5.5 with Adobe Flash Professional CS5.5 and promptly compiled my app with player10.3. but I still get the same error

authoring for 10.3 is still not officially supported even in Flash Pro CS5.5?