Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Auto number fields/adding table column problem

Avatar

Level 1

So frustrated.

I have a very simple form and a simple problem. I have saved the form as an Adobe Dynamic XML form pdf. and am editing it with this extension.

The form is flowable, with each field 'row' consisting of a left checkbox with right caption field. Some captions are also followed to the right by 2 fillable text fields followed again to the right by an add and remove row button which adds 2 new text fields for this checkbox in case the User needs them.

The single checkbox field heirachy is just a table>row>cell

The checkbox/2 fields/add/remove combo is:

Subform

  >subform>subform (Row)>Cell (Checkbox)

  >subform>table>row>

    >cell (field)

    >cell (field)

    >subform >add button

    >subform >remove button

My problem is after creating my terrific form, I have forgotten to number my checkboxes to the left of each checkbox which customers need for reference.

But I have the following problems:

a)All align options in menu are greyed out so can't align fields to right so that I can try putting text box or some other object for a number on the left

b)Select >Select all fields results in no action,even though the select all fields option is active

c)Selecting the cell of the checkbox and clicking insert column to left results in no action even though column insert option is active

d)x and y coordinates for all fields are also greyed out

e)If I select the left edge of the checkbox table to drag it right to give me room for my number, instead it reduces the length of the table, it doesn't shift the object to the right.

and so on. It seems as though there is some fundamental setting/set up I'm missing. You would think that automatic numbering of fields would be a frequently used function but I can't find in help whether there is some automatic way of doing this like there is with page numbers on a master page.

Lots of brownie points to someone who can tell me how to insert numbers to the left of my checkboxes!

Jess

4 Replies

Avatar

Level 10

You are working with a table ....by default each cell only allows one object inside of it. That being said you can fix your form in one of two ways ......add a positioned subform to the cell and in the subform put your static  text for the number and  the checkbox.......or add another column to the left of the checkbox and add a static text object to represent the number there.

Hoep that helps

Paul

Avatar

Level 1

Unfortunately, neither options are possible. With the first option, yes I can add a subform that contains both a checkbox and a text field however the fields refuse to be dragged next to each other, instead they sit on top of each other within the subform fixed to the left hand side of my content area.

Neither can I get 2 subform fields to display side by side, one with a text field and the other with a checkbox which is weird because previously I've been able to - that's how I created the expanding row heirachy.

Adding a subform also removes the existing checkbox caption and style, so even if it did work, i'd be in for a world of pain individually adding all checkboxes again. Both x,y, and height of the subform are greyed out.

The second option u mention is not available to me because inserting a column does not result in any action at all.

It feels like there's a basic function or understanding I'm missing out on, some 'trick' to getting 2 fields or subforms next to each other.

I really appreciate your help anyway.

Sent from my iPhone

Avatar

Level 1

Ok. It's taken me 5 hours to work this out but for anyone on this forum having problems with positioning... essentially Livecycle is all about subforms.

Whenever you want side by side fields that contain different object types, create subforms that contain tables that contain fields.

When dragging to resize, dragging the subforms seems to work best rather than dragging any part of a table, but you might have to experiment with which side of a subform to drag to get it in the right place.

Most importantly, if your options in the menu bar are grey, it could be because you have not selected 2 or more subforms and with the positioning like align, this option is meant for aligning two or more subforms as a group. I don't think these positioning options are meant for tables or rows.

If you have problems with right clicking on an object and selecting 'wrap in subform' giving you outcomes you don't want. I've found I've needed to create a new subform and then drag it in the heirachy and add the object to it there that way rather than wrapping it.

If you are having problems inserting a new column into a table, try just adding your desired object anywhere on your page and then dragging it in the heirachy to be a child of a row object. The first child in a row object seems to display on the left by default. The second child on the right etc.

So I reiterate, subforms,subforms, subforms, and then it should work. Maybe.