AMD Drivers installation issues on CentOS 7

sarahjohan

27-10-2018

Hello All,

I have been trying to install the AMD drivers on my CentOS computer for about a month now with no luck. I have followed the AMD guide; however, I get an error saying,

Error: Package: glamor-amdgpu-1.19.0-511655.el6.x86_64 (amdgpu-pro-local)

       Requires: xserver-abi(videodrv-19) >= 0

I have been working with AMD support this entire time and they don't seem eager to solve my problem in a timely manner.

I have checked that I have xserver and it is up to date and running.

What steps should I take to resolve this problem?

Result of running sudo bash -x amdgpu-pro-preinstall.sh

   +++ id -u

++ [[ 0 -ne 0 ]]

++ :

+ SUDO=

+ checkonly=false

+ err=false

+ os_release

+ [[ -r /etc/os-release ]]

+ . /etc/os-release

++ NAME='CentOS Linux'

++ VERSION='7 (Core)'

++ ID=centos

++ ID_LIKE='rhel fedora'

++ VERSION_ID=7

++ PRETTY_NAME='CentOS Linux 7 (Core)'

++ ANSI_COLOR='0;31'

++ CPE_NAME=cpe:/o:centos:centos:7

++ HOME_URL=https://www.centos.org/

++ BUG_REPORT_URL=https://bugs.centos.org/

++ CENTOS_MANTISBT_PROJECT=CentOS-7

++ CENTOS_MANTISBT_PROJECT_VERSION=7

++ REDHAT_SUPPORT_PRODUCT=centos

++ REDHAT_SUPPORT_PRODUCT_VERSION=7

+ case "$ID" in

+ name=RHEL

+ extra='Extra Packages for Linux (EPEL) Repository'

+ (( 0 ))

+ set --

+ false

+ cat

The amdgpu-pro driver requires access to specific RPMs from centos installation

media as well as access to Extra Packages for Linux (EPEL) Repository

This script will confirm that all required prerequisite files and repositories

are available in order to successfully install the amdgpu-pro driver. 

Press ENTER to continue . . ."

+ read

Accepted Solutions (0)

Answers (0)