Action won't run properly on PDF opened by other person

podperson

27-02-2017

I created a page in Acrobat X's LiveCycle Designer ES2 to be used as a form.  I saved my form as a PDF using the Reader Extended PDF, Enable Additional Features option (usage rights) so that other users can populate its fields with text and print it and/or save it. They have no access to any other features. Its been in use by multiple people for some time and I can confidently say everything works.

I haven't used Action Builder before, but decided to start simple and just fancy up one particular field which has a drop down menu with two choices in it: '0 Not Planned by MRP', or '2 Planned by MRP.' The default entry displays '2 planned in MRP.' If the user decides the correct entry is '2' they just leave it alone and move on. If the user decides the correct choice should be '0,' they select that and this is where my action comes into play...

If '0' is clicked on, the Action gives an alert box with some text explaining a few details regarding that choice. When they click on 'OK' to remove the alert box message, the background of the field turns red. Here's a pic of the first action -

Action Red 1.png

If the user changes their mind and decides they really wanted '2,' I created a second action which fills the background with no color (white) when the menu line showing '2' is clicked on.  Here's a pic of the second action -

Action White 2.png

I thought that was pretty simple and straightforward. I saved the form in Acrobat as a PDF with the option of Reader Extended PDF, Enable Additional Features.

I opened the form with Adobe Acrobat Reader DC and it works perfectly. I emailed the form to myself and it still works. Yea me!  However, when I send it to anyone else and they open it and go to that particular drop-down menu things start to go haywire.

  • The default of '2' displays correctly and background is white.
  • If user opens the drop-down menu and clicks on '0' they get the alert box message. So far, so good.
  • But when they click on 'OK' to get rid of the alert box, the box duly disappears but the background of the field doesn't turn red, it remains at its default color: white.

Now, this mystifies me because I figure if the Action isn't available to another user in the saved version, then why does the first part of the action - showing the message box - work at all? If some of it works, then why not all of it?  How do I make this work for other users?

Any suggestions as to where I'm going wrong or what I haven't done? I would greatly appreciate it.

Many thanks in advance.

Accepted Solutions (0)

Answers (0)