Expand my Community achievements bar.

July 31st AEM Gems Webinar: Elevate your AEM development to master the integration of private GitHub repositories within AEM Cloud Manager.

Workbench won't copy/paste nodes


Former Community Member
Hello all,

I have some sections of a process that are very similar, and would like to copy/paste them so that I don't have to set up each node individually again. The nodes I'm trying to copy/paste are on a branch inside a gateway element. Workbench is acting rather funny about this. Some nodes will copy/paste fine, but the majority will not. I've also tried to copy the entire branch but this has the same outcome as those nodes that won't copy/paste. Sometimes the nodes will copy/paste but workbench won't recognize that they are there (meaning they show up on the workflow, but when you try to click on them to set properties workbench never selects the node, and lists "Nothing Selected" in the properties window). The JBoss log does not show any errors, but if I dig into the Eclipse log, I see the following errors:

!ENTRY org.eclipse.ui 4 4 2008-07-07 12:52:32.771

!MESSAGE Unhandled event loop exception

!ENTRY org.eclipse.ui 4 0 2008-07-07 12:52:32.771

!MESSAGE java.lang.NullPointerException



at com.adobe.workflow.eclipse.template.ProcessTemplateView.acceptOrRejectPaste(ProcessTemplateView.java:1175)

at com.adobe.workflow.eclipse.template.ProcessTemplateView.paste(ProcessTemplateView.java:1098)

at com.adobe.workflow.eclipse.template.AbstractTemplateView.doMouseUp(AbstractTemplateView.java:1039)

at com.nwoods.jgo.JGoView.mouseUp(Unknown Source)

at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:137)

I've tried restarting Workbench, and the LiveCycle server, but neither will allow the copy/paste to happen. Anyone else ever seen this, or know how to resolve it?
0 Replies