Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Web Service and flowable subform

Avatar

Avatar
Level 5
_jerome_dinnat_
Level 5

Likes

0 likes

Total Posts

180 posts

Correct Reply

0 solutions
View profile

Avatar
Level 5
_jerome_dinnat_
Level 5

Likes

0 likes

Total Posts

180 posts

Correct Reply

0 solutions
View profile
_jerome_dinnat_
Level 5

10-07-2008

Hi,



I call a web service in my form to retrieve some fields.

I retrieve a list of users (login ,name, email etc ...).



I want when I click on the button that all the fields appear in a table.



I try to drag and drop the connection body to the form design. It create me a table in a flowable subform with an overflowleader and fields that look well. In the binding tab I check that Repeat is check but when I click on the form there is only one row fill in.



Thanks for the help 🙂



Edit : the form is an interactive pdf form.



For example the web service return me 4 users.

If I click on the button only the first user data creating a row.

If I fill 4 in the repeat min box, the 4 rows with data appear but I can specify this value, it depends on what the users choice.



I try to add script in the button :



MyNodeToRepeat.instanceManager.addInstance(0);



but I need to click 4 times on the button.

Replies

Avatar

22-07-2008

If you selected the "remember my action" box and clicked "Yes" then you won't see the security warning again.



I believe your remaining issue is that the submit doesn't work. Is that correct? As a test, try adding another submit button to your form but don't change any of the scripting. Does the second button work when you click it in Acrobat?



Ernest

Adobe Systems

Avatar

Avatar
Level 5
_jerome_dinnat_
Level 5

Likes

0 likes

Total Posts

180 posts

Correct Reply

0 solutions
View profile

Avatar
Level 5
_jerome_dinnat_
Level 5

Likes

0 likes

Total Posts

180 posts

Correct Reply

0 solutions
View profile
_jerome_dinnat_
Level 5

23-07-2008

Hi,



I added another submit button to my form but it doesn't work too.



I try to view the xml source for the dropdown box issue but my designer crashes every time I try with this form.



I posted another topic http://www.adobeforums.com/webx/.59b5eae2 if you have any ideas.



Thanks

Avatar

24-07-2008

I'm sorry you're having such difficulty with your form. I see Paul is looking at the other topic you posted. Can you post the full build number for your version of Designer (Help, About)?



Ernest

Adobe Systems

Avatar

Avatar
Level 5
_jerome_dinnat_
Level 5

Likes

0 likes

Total Posts

180 posts

Correct Reply

0 solutions
View profile

Avatar
Level 5
_jerome_dinnat_
Level 5

Likes

0 likes

Total Posts

180 posts

Correct Reply

0 solutions
View profile
_jerome_dinnat_
Level 5

24-07-2008

The full build number of my version of Designer is 8.2.1.3144.1.471865.



Thanks 🙂