Highlighted

Tooltip with XML and XSD in Designer

Avatar

12-01-2009

Hi, I have problem with getting the tooltip to work when I hover over a simple textfield. I have activated the Dynamic properties, connected to the XSD and the corresponding XML-file. I connect to the schema in Accessibility but I can´t chose whith @ (ex @dp_tt) as I suposed to before the string. How can a simple XSD look like? How can the corresponding XML look like? Where can I find a good example anywhere? The Adobe Livesycle Designer Help gives me no help because it only shows fragment from the XML-file.



I would be thankful for anyone who have an idea what the problem is or where i can read about it.



Rikard

Replies

Highlighted

Avatar

Avatar

pguerett

Total Posts

7.7K

Likes

611

Correct Answer

692

Avatar

pguerett

Total Posts

7.7K

Likes

611

Correct Answer

692
pguerett

12-01-2009

Are you sure the node that holds the string is populated with a value? The string should be in the xml file and not in the XSD. If I merge a sample xml file (that follows my defined XSD) and ensure that the bound node is populated it works fine (I tried it here).
Highlighted

Avatar

12-01-2009

Hi again, now I´ve fixed the @-problem with an attribute in XSD but the tooltip doesn´t pop up when I hover over the textfield. I think the connection now is right but there is more details about this that is missing. Where can I read about more about Tooltip in Designer using XSD and XML?
Highlighted

Avatar

12-01-2009

Yes, the XML string is populated with the message. Can you please share an example of a XML- and XSD-file? It would be great to see something that works. Thanks for answearing.
Highlighted

Avatar

Avatar

pguerett

Total Posts

7.7K

Likes

611

Correct Answer

692

Avatar

pguerett

Total Posts

7.7K

Likes

611

Correct Answer

692
pguerett

12-01-2009

You must post your email address so I can send it to you.
Highlighted

Avatar

12-01-2009

That would be great and very kind of you. Here is my e-mail:



rikard.werge@gmail.com



Thanks again.

Rikard
Highlighted

Avatar

14-01-2009

Hi again, I´m still trying to dynamically populate a tool tip but can´t find out why it´s not working. Are anyone getting this to work when you connect to an external xml and xsd? I think that I don´t know the connection through namespace is working and that I need to see a real example where it is working.



Can somebody give me an example of two working files: XML and XSD that gives a tool tip?
Highlighted

Avatar

Avatar

pguerett

Total Posts

7.7K

Likes

611

Correct Answer

692

Avatar

pguerett

Total Posts

7.7K

Likes

611

Correct Answer

692
pguerett

14-01-2009

Just sent you a sample
Highlighted

Avatar

Avatar

upkachora

Avatar

upkachora

upkachora

22-04-2009

Hi Mr Guerett

Can you please also send me the sample. My email address is manoj_goel@msn.com

Also I have a need to extract the help from html file for each section on my form how can I do that?

Thanks

Manoj