Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Submit Button In Workbench process stalls


Not applicable
Hi all, I am new to workbench, and just getting my head around all this.

I am looking at the mortgage loan example, and I start the process fine, but when I click on the submit button, it gives me a blank page, and the to do is still there.

to do (1)

There is a message in the bottom of the browser (In the bottom bar) that cycles between "Transferring Data" and "Waiting for reply"

Is the form being sent to the wrong place?

Thank you all for your help.
20 Replies


Not applicable
Okay, I finally noticed that the

"User MUST select a rout before completing this task" was clicked.

Even though I select the rout thru the list it still stalls.

but now that I un-click it, it chooses it chooses the top path on the rout list.

Any ideas?


Level 10
Make sure the "Initialize Task with Route Name" is selected in the Route section. Then you should be able to select the route you want.



Not applicable
Hi Jasmin,

Thanks for your reply, that is clicked as well.

If the first isn't selected I do not have the second option available.

This is what I have for my process.

User1 -(approve)-> User2

User1 -(deny)-> User3

In the rout evaluation:



Routs and Priority:

[X]Initialize Task With Route Name

[X]User Must Select Rout To Complete Task

If I enable the form, and run the process, if "User Must Select Route..." is checked. I select the rout. and when I submit, it turns to a white page, and nothing happens.

If I unclick that box, it just takes whatever route is at the top of the list, even if I select (deny) "the other one".

This also happens with the demo, mortgage form.

Thanks for any suggestions.


Level 10
What render service are you using on that variable?

Are you using a submit service?



Not applicable
Hi Jasmin,

For that question, I honestly do not know, I can't really find any documentation on a step by step explanation of workbench at all, except for "Open the Mortgage Loan example" and I have. Yet, it gives me this problem.

And it seems the only place I have gotten at least a point in the right direction reply is here, and I thank you for that.

I tried to make my own work flow as well, and it does the same thing.

Is it my fault? The server? The designer?

Sorry I seem a bit helpless, but I truly feel I am a chicken running around with its head cut off.

Should I not enable the forms in reader extension? Should I? Should I use the XDP? etc.

Sorry, I don't know how to answer that one.




Not applicable
In the variable properties, click the Advanced Settings button. The Render tab is where you configure the render service.

To deliver the form as PDF, the render service should be Submit PDF Form.



Not applicable
> Jasmin

Yes, thats where I got the mortgage loan, and have pretty much the same issue with that one.

I will try and go through it one more time to see if I find anything.

> Scott





Not applicable
I think recently solved the same problem.

If so, can you tell us where your Submit button is placed?

Is he in the Reader plug-in window or is it placed outside the Form at the bottom right of the Flex UI.

Also, do you see Buttons for your 2 routes, or is there a combobox?

Problem could be Firefox, try IE if not already done so.



Not applicable
I am Mish's college.

There is definitely something wrong with the default submit service.


* pdf, non enabled (although enabled now produces the same results)

* form fields included using the designer, no modifications


* using standard render

* using standard submit (that is enable submit service is NOT clicked)

* routes are Approve, Deny

* buttons do NOT display in the flex UI (on open form) but as drop downs in the form (this behavior changed i believe around SP2, before they showed in the flex UI)

* if "User must select a route to continue" is checked livecycle throws an error "submit service ... route: null invalid" and the submit stalls

* if "User must select a route to continue" is unchecked the process ALWAYS chooses the first route regardless of what is selected (regardless of the browser)

A few observations:

* The two quick buttons still show on the process card, selecting deny from here does select the correct path

* enabling the "send form to user" in server settings and submitting the form from there (using complete task + email endpoint) selects the correct path

This leads me to believe that the form is working as intended, that the buttons are correctly identified but that something in SP2 broke the flex UI with an open form.

All of the 20 forms we are using displays the same behavior, even creating a workflow out of two elements (a user that links back to itself with deny and an empty decision point with approve) does not solve the issue.

So to solve this issue i have to add a condition to the first route (or all routes) that check /proces_data/*form*//AWS_ACTION

This seems to be a workaround although it is pretty silly


Not applicable
Joerg Meyer: "buttons do NOT display in the flex UI (on open form) but as drop downs in the form (this behavior changed i believe around SP2, before they showed in the flex UI) "

As mentionend above I had the same behaviour (buttons where suddenly gone). I figured out that in our case, the problem was the flash-plugin of Firefox 3. I didn't change anything in the form or the process and just changed to IE and the buttons showed up correctly.

Maybe this helps.


Level 10
The buttons not showing up can also be caused by two other things:

The Inject Form Bridge has not been applied to the PDF. This is usually done in the renderPDFForm from Samples, but if you use your own render, you might not have it.

If you have more than one Submit buttons on your form, it might confuse the JavaScript that hides the submit button and show the buttons from the Workspace interface.



Not applicable

ah yes, i believe you are correct. I have seen the buttons show up on IE.

My concern here is not the buttons showing or not. I couldn't care less about useless bells and whistles.

My primary concern here is:

Someone puts in a request for a million dollars, the approver hits deny and the workflow progresses further down the "approve" path. (or whatever the first route is out of the node)

This ONLY happens if the form is opened in workspace. It does not happen using the quick buttons nor does it happen using offline submit.

AWS_SUBMIT DOES contain "Deny" correctly so i am at a complete loss.

Putting an additional check on all approve paths such as "/process_data//AWS_SUBMIT"="Approve" solves this problem and may be "best practice" but this should not be required.

In fact the mortgage loan sample coming with livecycle has exactly the same problem.

Furthermore selecting "user must select path to continue" breaks workspace.

Pending submit and puts form into draft, can never be deleted or completed and is forever in the users todo list.


Level 2
Hi everybody, <br />I guess my problem is related with this topic. I have small process include just two components, an execute and an Execute SQL Statement. <br />On workspace, I fill in the form (defined as xfa variable) and click the complete button, then data on the form is being recorded.<br /><br />But on workspace, when I take the form offline and submit it (by using acrobat 9 pro. ext.) I get an error message. It attempts to reach the server but gets this error: "Error:Nothing Done Invalid Server Response http://<server_ip>:8080/workspace-server/submit"<br /><br />Do you have any suggestion? What correction do I need?


Level 10
Is your submit button part of the LiveCycle Process Fields (from Designer) or you added the submit button yourself?



Level 2
Hi, thanks for reply

I drag/drop submit button on LC Designer. It's kontrol type is "Submit" and ,it submits as "XML Data Package (XDP)"

Thanks in advance..



Level 10
The offline capability is really email based.

Try to drag the Process fields from Form Designer which will also give you a submit button, but there will be some script to send an email if you're not in a web browser.



Not applicable
hi Jasmin,

I'm totally confused with LC ES and LC Designer ES. I have created PDF forms and i had the forms emailed by Admin via a click of submit button. And the form had to filled by employee then verified by customer and finally to Admin. Everything worked fine but as per the client requirement i was supposed to export the form datacontent to CSV format. So i though i could rely on LC workbench ES as you have asked to do so. But i feel that as i read through many articles the process is done only on Online i suppose. Is that correct Jasmin? If so the PDF forms that i have currently working in offline will not be able to submit the content alone to this process i suppose. Please help me out with possible solution..

My main requirement is to export the XML content to CSV. Can this be done using LC designer alone. If so let me know.. I have installed the trial version of LC ES. That's taking off my whole time if i choose any other application. Even google search doesnt come up. Its very slow..