Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

[AEM Gems Webinar] Accelerating Experience Manager as a Cloud Service development with Rapid Development Environments

remoteObject fault code is not returned on firefox 2.0 but same returns fault code on Internet explorer

Avatar

Not applicable
Hi,

I am compiling flex application on server (tomcat 6.0) and
using browser firefox2.0 . The application runs well , but whenever
I shutdown server and still try to access application functionality
, it don't return any fault code and noting happens.

The same application runs well on Internet Explorer 6.0, and
when i shutdown server and access application functionality it
gives fault code alert.

I have used the connection timeout property with
remoteobject but then also it do not show fault code with the
remoteobject on firefox.

I need the solution early...can any one help me out..please
if any one know reply soon.
3 Replies

Avatar

Level 2
it's because you browser (in this case FF) has cached th
response. Try to add a dummy timestamp to your URLs to force the
browser to go to the server on each request:



var dummy:Number = new Date().getTime();



myURL += "&dummy="dummy

Avatar

Not applicable
hi,

I am not getting the solution u provided , you have said to
add dummy timestamp with url, but i am not using any url

i my application. so wil you please explain it.