Expand my Community achievements bar.

July 31st AEM Gems Webinar: Elevate your AEM development to master the integration of private GitHub repositories within AEM Cloud Manager.

Problem with the configuration of a data service


Level 1

I'm facing some strange problems to get the CRM sample to run.

Firstly, I ran it from the lcds-samples.war, and it works perfectly, but when I build an Eclipse project: New -> Dynamic Web Project ( exactly how I made when works on BlazeDS ), put the libraries and the configuration files ( the same as the lcds-samples.war ) I got an error when the Tomcat starts:

flex.messaging.config.ConfigurationException: Unrecognized tag found
in <properties>.  Please consult the documentation to determine if the
tag is invalid or belongs inside of a different tag:
  '/server/fill-method' in destination with id: 'crm-company' from
file: data-management-config.xml
  '/server/fill-method' in destination with id: 'crm-employee' from
file: data-management-config.xml

P.S: I tried also with the 'fill-method' tag outside the 'server' tag and also the tag as only 'fill'.

The compiler is saying that the fill-method tag is unrecognized and I need to consult the documentation.Right...

In the Adobe Livecycle Data Services ES2 3.1 documentation (updated 5/3/2010) in the page 255 contains a table with the tags accepted to configure a destination with a Custom Assembler, and one of these properties is the fill-method.

I tried also to remove this tag fill-method.And now it compiles!

However when I run the project.Throw me an error:

Missing or invalid configuration for destinations: ["crm-company","crm-
Could not initialize DataService

2 Replies


Level 1

It was solved.


*Unrecognized tag: The fill-method tag is used only in the fill-method approach and this approach didn't work with Custom Assebler.

*Missing or invalid destinations: The RTMP port was not getting connected



Can you please provide the complete exception so that i can help you out with this.