Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Problem with an ALC-WKS-007-040 error

kc
Level 8
Level 8
Hi all,



I'm trying to develop a BP with forms in XDP. However this does not work as I get an ALC-WKS-007-040 error when I try to render the form in Workspace. I have tried to set up the renderPDF instead of the default renderer, but I still get an error. When I use PDFs instead of XDPs it works fine (with the default renderer).



What can I do to fix my problem?



Thanks in advance



Kim Christensen

Dafolo A/S

Denmark
0 Replies
Not applicable
You can use the RenderPDFForm service from the Forms samples as the render service.



Chris Trubiani

Adobe Systems
kc
Level 8
Level 8
Hi Chris,



Yes, this is also what I have read in another post. However I am not sure how I should setup the specific properties for ths service. I tried with the settings suggested by Jasmin in http://www.adobeforums.com/webx/.3bc7e99e however I end up with the same error when I invoke my process in Workspace.



Cn you give me a pointer of where to look for the cause?



Thanks again



Kim Christensen

Dafolo A/S

Denmark
Jasmin_Charbonn
Level 10
Level 10
Can you check the server.log file under ...LiveCycle8/jboss/logs?



Also are you using an XDP file?



What service are you usging to render the form?



Jasmin
kc
Level 8
Level 8
Hi again,



Yes, I have checked the logs, however i am not really sure how to interpret them. I seem to get some kind of exception in JBoss.



I am using an XDP file with an embedded xml-schema and I have tried using both the renderPDFForm (under Forms) and the Samples - Forms - RenderPDFForm service.



If I use an PDF file with the same embeded xml-schema I don't get any errors rendering the file.



I tried to follow your guide in http://www.adobeforums.com/webx/.3bc7e99e but as mentioned in my earlier post I still get an error.



I hope that we can solve this problem as it would be quite beneficial for the project I doing to use XDP instead of PDF.



Thanks in advance



Sincerely



Kim Christensen

Dafolo A/S

Denmark
Jasmin_Charbonn
Level 10
Level 10
You have to use the Samples - Forms - RenderPDFForm service.



Can you tell me how you set you settings for the render service?



Jasmin
kc
Level 8
Level 8
I try to set the following using the Samples - Forms - RenderPDFForm:



Service Input:



- formUrl - task - Form URL



- inDocData - task - Form Data (however I consider this an optional field)



- targetURL - Custom Configuration - targetUrl



- userAgent Custom Configuration - userAgent



Service Output:



outFormDoc - task - Document



This is my settings, however it still seems to cause an error.



I think I'll try with another form (just to rule out that posibility). If you have any other suggesrions to what I could try out I would be all ears 🙂



Thanks again for your effort, I really appreciate it.



Sincerely



Kim Christensen

Dafolo A/S

Denmark
Not applicable
Well, that looks right. What exactly is showing up the logs?



Chris
kc
Level 8
Level 8
OK, I have rechecked the problem and now it is no longer the ALC-WKS-007-040 error i get. Instead I get the ALC-WKS-007-027 error with a server log that looks almost identical with the one Chaos Mao has posted in http://www.adobeforums.com/webx/.3c053a77/3



I hope that you can help me with this issue.



Sincerely



Kim Christensen

Dafolo A/S

Denmark
kc
Level 8
Level 8
Hi again,



I fixed it now, somehow all my users from the LDAP were lost in the server. So a new synchronize helped alot.



However I am very grateful of your efforts to help. Thanks guys.



Kim Christensen

Dafolo A/S

Denmark
kc
Level 8
Level 8
Argh...



I did not fix the problem at all.



Now I am back at the 007-040 render error. I have set up the service as mentioned above and the server log reports back that it cannot locate some pdf-file. However I have set up my process variable to point to an xdp-file.



Snippet of the log:



exception: flex.messaging.MessageException: ALC-WKS-005-028: A problem occurred in the Render Service. Please review the render orchestration for this process.

2007-11-05 15:18:30,176 INFO [STDOUT] [Flex] [ERROR] Root cause: ALC-DSC-003-000: com.adobe.idp.dsc.DSCInvocationException: Invocation error.

at com.adobe.idp.dsc.component.impl.DefaultPOJOInvokerImpl.invoke(DefaultPOJOInvokerImpl.java:210)

at com.adobe.idp.dsc.interceptor.impl.InvocationInterceptor.intercept(InvocationInterceptor.java:134)

at com.adobe.idp.dsc.interceptor.impl.RequestInterceptorChainImpl.proceed(RequestInterceptorChainImpl.java:44)

at com.adobe.idp.dsc.transaction.interceptor.TransactionInterceptor$1.doInTransaction(TransactionInterceptor.java:74)

at com.adobe.idp.dsc.transaction.impl.ejb.adapter.EjbTransactionCMTAdapterBean.execute(EjbTransactionCMTAdapterBean.java:336)

at com.adobe.idp.dsc.transaction.impl.ejb.adapter.EjbTransactionCMTAdapterBean.doRequired(EjbTransactionCMTAdapterBean.java:259)

at sun.reflect.GeneratedMethodAccessor535.invoke(Unknown Source)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

at java.lang.reflect.Method.invoke(Method.java:585)

at org.jboss.invocation.Invocation.performCall(Invocation.java:345)

at org.jboss.ejb.StatelessSessionContainer$ContainerInterceptor.invoke(StatelessSessionContainer.java:214)

at org.jboss.resource.connectionmanager.CachedConnectionInterceptor.invoke(CachedConnectionInterceptor.java:149)

at org.jboss.ejb.plugins.StatelessSessionInstanceInterceptor.invoke(StatelessSessionInstanceInterceptor.java:154)

at org.jboss.webservice.server.ServiceEndpointInterceptor.invoke(ServiceEndpointInterceptor.java:54)

at org.jboss.ejb.plugins.CallValidationInterceptor.invoke(CallValidationInterceptor.java:48)

at org.jboss.ejb.plugins.AbstractTxInterceptor.invokeNext(AbstractTxInterceptor.java:106)

at org.jboss.ejb.plugins.TxInterceptorCMT.runWithTransactions(TxInterceptorCMT.java:335)

at org.jboss.ejb.plugins.TxInterceptorCMT.invoke(TxInterceptorCMT.java:166)

at org.jboss.ejb.plugins.SecurityInterceptor.invoke(SecurityInterceptor.java:153)

at org.jboss.ejb.plugins.LogInterceptor.invoke(LogInterceptor.java:192)

at org.jboss.ejb.plugins.ProxyFactoryFinderInterceptor.invoke(ProxyFactoryFinderInterceptor.java:122)

at org.jboss.ejb.SessionContainer.internalInvoke(SessionContainer.java:624)

at org.jboss.ejb.Container.invoke(Container.java:873)

at org.jboss.ejb.plugins.local.BaseLocalProxyFactory.invoke(BaseLocalProxyFactory.java:415)

at org.jboss.ejb.plugins.local.StatelessSessionProxy.invoke(StatelessSessionProxy.java:88)

at $Proxy199.doRequired(Unknown Source)



Further down the "cause" is stated:



Caused by: com.adobe.repository.ResourceNotFoundException: ALC-REP-018-000: Resource [/Friplads/Forms/Svar/somepdf.pdf] does not exist or you do not have sufficient rights to access it.

at com.adobe.repository.commands.ReadResourceCommand.execute(ReadResourceCommand.java:209)

at com.adobe.repository.commands.ReadResourceContentCommand.execute(ReadResourceContentCommand.java:113)

at com.adobe.repository.commands.CommandProcessor.execute(CommandProcessor.java:124)

at com.adobe.repository.bindings.dsc.RepositoryProviderServiceImpl.readResourceContent(RepositoryProviderServiceImpl.java:642)

at sun.reflect.GeneratedMethodAccessor813.invoke(Unknown Source)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

at java.lang.reflect.Method.invoke(Method.java:585)

at com.adobe.idp.dsc.component.impl.DefaultPOJOInvokerImpl.invoke(DefaultPOJOInvokerImpl.java:181)

at com.adobe.idp.dsc.interceptor.impl.InvocationInterceptor.intercept(InvocationInterceptor.java:134)

at com.adobe.idp.dsc.interceptor.impl.RequestInterceptorChainImpl.proceed(RequestInterceptorChainImpl.java:44)

at com.adobe.idp.dsc.transaction.interceptor.TransactionInterceptor$1.doInTransaction(TransactionInterceptor.java:74)

at com.adobe.idp.dsc.transaction.impl.ejb.adapter.EjbTransactionCMTAdapterBean.execute(EjbTransactionCMTAdapterBean.java:336)

at com.adobe.idp.dsc.transaction.impl.ejb.adapter.EjbTransactionCMTAdapterBean.doRequired(EjbTransactionCMTAdapterBean.java:259)

at sun.reflect.GeneratedMethodAccessor535.invoke(Unknown Source)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

at java.lang.reflect.Method.invoke(Method.java:585)

at org.jboss.invocation.Invocation.performCall(Invocation.java:345)

at org.jboss.ejb.StatelessSessionContainer$ContainerInterceptor.invoke(StatelessSessionContainer.java:214)

at org.jboss.resource.connectionmanager.CachedConnectionInterceptor.invoke(CachedConnectionInterceptor.java:149)



The funny thing is that this pdf is not the one that I have referred to through my process variable (neither is it the name of the .xdp file).



I am really confused by this, could you in short explain to me how I should understand this kind of error. To me it seems like some pointer is definitelly not set right, however my process have become so big that it is a rather big task to check all references.



I would really be grateful for some hints to how I could proceed.



Sincerely



Kim Christensen

Dafolo A/S

Denmark
Not applicable
Kim, on your XDP form do you have the "Adobe LiveCycle Form Bridge" and "Process Fields" on your form? Both are found in the custom library.
HowardTreisman
Level 9
Level 9
Hi Kim

The question is: Why is it complaining about [/Friplads/Forms/Svar/Brev_til_svarfrist_paed_friplads_v0r0m0.pdf?

Where does this form definition come from?

The server is unlikely to make up this name, so it must come from somewhere 🙂

Howard

http://www.avoka.com
Jasmin_Charbonn
Level 10
Level 10
The render service of a form variable that tries to render your form points to a form located at /Friplads/Forms/Svar/somepdf.pdf which doesn't seem to exist.



Jasmin
kc
Level 8
Level 8
Hi again, I'll try to answer your questions as good as I can.



However can tell you that I made a small process with only one form and I got it to render (then got another problem - read my other post), however I got the small process to render the xdp file.



Lee:

Yes, I have the "Process Fields" on the form, but I did not have the "Form Bridge". I will look into this as ine of my next tasks.



Howard:

I see your point 🙂 Let me try to explain the situation. As I have been implementing the process I ran into the problem (among others 🙂 ) with rendering the xdp-files. So I tested with pdf's instead and to my surprise it worked perfectly. Hence I have used references for pdf-files throughout the entire process.

However I do not understand that the server complains about this file (I guess the server is interpreting (and not compiling) the process description as it goes along. And as I have no reference to the pdf at ([/Friplads/Forms/Svar/Brev_til_svarfrist_paed_friplads_v0r0m0.pdf) in the initial step of the process I don't understand it.



Jasmin:

No it is true that it does not exist, however the xdp variable that I have set up for the initial step does not have any coherence with the form in /Friplads/Forms/Svar/Brev_til_svarfrist_paed_friplads_v0r0m0.pdf



So in short I am happy that I got the simple process to render a xdp-file however I fear that I have to start all over with my large process to make it work with xdp.



I am still very grateful for your effort to help, and if you have any good ideas for me I would really like to hear them out.



Sincerely



Kim Christensen

Dafolo A/S

Denmark
Not applicable
Hi,



I am newby on Livecycle,

and currently trying the same thing. Prepopulating my form with user information when first user (starter) opens the form from workspace.



I did the things proposed by Jasmin.

Now I set

userID -- task -- user's id



as proposed, in Sample Form/Render PDF Form.



It's ok. I mean no error. I can open the form from workspace.

What I want to do is to get the username from user ID, and put it

in a field in the form that user can see his name when he/she opens

the form.



Could you please tell me how can use this variable to get the user name and how to set it to the field in my form.



Thanks in advance



Cihan
Jasmin_Charbonn
Level 10
Level 10
Kim,

Would you, by any chance, have more than one form variable that are IN. You need to make sure you have only one form variable of type IN since there can be only one form being rendered in Workspace. If you have more that one, then it may pick the wrong one.



The form is going to be rendered before your initial step in your processes (depending of the IN variables) so I don't think the problem is with your initial step's configuration.



Jasmin
kc
Level 8
Level 8
Thanks Jasmin...



That did the trick, I feel so stupid for not realizing this myself. Nevertheless you learn as long as you live...



Thanks for the effort...



Sincerely



Kim Christensen

Dafolo A/S

Denmark
Not applicable
I got the same error when trying to Initiate a process in WorkSpace. However, it seems that the problem maybe different from the discussions above.



I am using something similar to the "Samples - Forms - Render PDF form 1.0" to render my XDP form, there's only one xfaForm var.



I put some Loggers in the Render service, and it seems that it got an exception at the "render Form" activity. I'll try to paste some lines in the systemOut.log below if there's room for it.



Note: this render was working fine before, but it stopped working all of a sudden. The only changed to the server (that I know of) was that they changed the network domain of the server. IP address has not been changed though. Restarting/Rebooting the server did not fix the problem.



Any idea how to fix it please?



LOG:

[2/29/08 17:28:57:738 CST] 000000f9 ProcessResour W com.adobe.service.ProcessResource$ErrorReaderThread run BMC024: Service XMLFormService: Process ProcessResource(name=XMLForm.exe,pid=0) terminated abnormally with error code {3}

[2/29/08 17:28:57:832 CST] 0000003c ProcessResour A com.adobe.service.ProcessResource startProcess BMC505: Service XMLFormService: Starting native process with command line "D:\\IBM\\WebSphere\\AppServer\\installedApps\\adobe\\server1\\XMLFormService\\bin\\XMLForm.exe" -MyPath D:\IBM\WebSphere\AppServer\installedApps\adobe\server1\XMLFormService -IOR IOR:00bdbdbd0000002249444c3a636f6d2f61646f62652f736572766963652f4d616e616765723a312e3000bdbd0000000100000000000003f1000102bd0000001545434443414c43544d5330312e7473742e636e7000bd238c000000204c4d4249000000154773e3aa001600060542522d32390008010000000000000000000009000000010000001400bdbdbd0501000100000000000101000000000049424d0a0000000800bd00011500000100000026000000020002bdbd49424d04000000050005020102bdbdbd0000001f0000000400bd0003000000200000000400bd0001000000250000000400bd000300000021000002780001bdbd000000040002bdbd000000240000001c00bd00260002bdbd000000010000000a6c6f63616c686f73740024bb004000000000000806062b1200021e02000000280401000806062b1200021e020000001864656661756c7457494d46696c6542617365645265616c6d0000000000000001494210ce0000001d0000001964656661756c7457494d46696c6542617365645265616c6d00bdbdbd00000000000000000042bdbd000000240000001c00bd00660042bdbd000000010000000a6c6f63616c686f73740024ba004000000000000806062b1200021e02000000280401000806062b1200021e020000001864656661756c7457494d46696c6542617365645265616c6d0000000000000001494210ce0000001d0000001964656661756c7457494d46696c6542617365645265616c6d00bdbdbd00000000000000000002bdbd000000240000001c00bd00260002bdbd000000010000000a6c6f63616c686f73740024bb00400000000000080606678102010101000000280401000806066781020101010000001864656661756c7457494d46696c6542617365645265616c6d0000000000000001494210ce0000001d0000001964656661756c7457494d46696c6542617365645265616c6d00bdbdbd00000000000000000042bdbd000000240000001c00bd00660042bdbd000000010000000a6c6f63616c686f73740024ba00400000000000080606678102010101000000280401000806066781020101010000001864656661756c7457494d46696c6542617365645265616c6d0000000000000001494210ce0000001d0000001964656661756c7457494d46696c6542617365645265616c6d00bdbdbd000000000000000049424d21000000b500bd00010000bdbd00000007435553544f4d00bd0000002149424d20576562537068657265204170706c69636174696f6e2053657276657200bdbdbd00000008362e312e302e35000000000931322f32382f303600bdbdbd0000000b636635303635322e313200bd000000492863656c6c293a45434443414c43544d5330314e6f6465303143656c6c3a286e6f6465293a45434443414c43544d5330314e6f646530313a28736572766572293a7365727665723100 -AppServer websphere

[2/29/08 17:28:58:082 CST] 0000003c XMLFormAgentW E com.adobe.livecycle.formsservice.logging.FormsLogger logMessage ALC-FRM-001-004: Unable to find service: XMLFormService, error: Connection to failed service.

[2/29/08 17:28:58:316 CST] 0000003c SystemOut O [Flex] Exception when invoking service: remoting-service

with message: Flex Message (flex.messaging.messages.RemotingMessage)

operation = render

clientId = 94BFCC50-CB0E-E92D-7542-90FE2FDA735A

destination = task-actions

messageId = 3605BD44-E968-AA3E-99D2-6786AD2964B0

timestamp = 1204327722235

timeToLive = 1204327722235

body = null

hdr(DSId) = 94158DE5-2F1A-7D2B-BB49-AFE0F218D777

hdr(DSEndpoint) = workspace-polling-amf

exception: flex.messaging.MessageException: ALC-WKS-005-028: A problem occurred in the Render Service. Please review the render orchestration for this process.



[2/29/08 17:28:58:316 CST] 0000003c SystemOut O [Flex] [ERROR] Exception when invoking service: remoting-service

with message: Flex Message (flex.messaging.messages.RemotingMessage)

operation = render

clientId = 94BFCC50-CB0E-E92D-7542-90FE2FDA735A

destination = task-actions

messageId = 3605BD44-E968-AA3E-99D2-6786AD2964B0

timestamp = 1204327722235

timeToLive = 1204327722235

body = null

hdr(DSId) = 94158DE5-2F1A-7D2B-BB49-AFE0F218D777

hdr(DSEndpoint) = workspace-polling-amf

exception: flex.messaging.MessageException: ALC-WKS-005-028: A problem occurred in the Render Service. Please review the render orchestration for this process.



[2/29/08 17:28:58:316 CST] 0000003c SystemOut O [Flex] Root cause: ALC-DSC-003-000: com.adobe.idp.dsc.DSCInvocationException: Invocation error.

at com.adobe.idp.dsc.component.impl.DefaultPOJOInvokerImpl.invoke(DefaultPOJOInvokerImpl.java:210)

at com.adobe.idp.dsc.interceptor.impl.InvocationInterceptor.intercept(InvocationInterceptor.java:134)

at com.adobe.idp.dsc.interceptor.impl.RequestInterceptorChainImpl.proceed(RequestInterceptorChainImpl.java:44)

at com.adobe.idp.dsc.transaction.interceptor.TransactionInterceptor$1.doInTransaction(TransactionInterceptor.java:74)

at com.adobe.idp.dsc.transaction.impl.ejb.adapter.EjbTransactionBMTAdapterBean.doRequiresNew(EjbTransactionBMTAdapterBean.java:218)

at com.adobe.idp.dsc.transaction.impl.ejb.adapter.EJSLocalStatelessEjbTransactionBMTAdapter_3af08fdf.doRequiresNew(Unknown Source)
Jasmin_Charbonn
Level 10
Level 10
The ALC-WKS-007-040 error is thrown when the render service is not able to render the document properly. This can be caused by various reasons.



In James's case, it looks like the Forms service (renderPDFForm) is not available for some reason (Unable to find service: XMLFormService). Have you try just to reboot the server?



In Kim's case we need more info. Can you post the stack trace. IF you use an XDP, then you need to use the renderPDFForm service from the Samples - Forms and not the Default render service. The Default render service is only used if you use a PDF and not an XDP.



Let me know,



Jasmin
Not applicable
Hi Jasmin, thanks for the response.



I am pretty sure (by checking the logs and by putting some variable loggers into the process) that it errors out at the Forms. I have tested the "Samples - Forms - Render PDF form 1.0", and it's not working for the XDP forms. However, the "Default Render" service works fine when rendering a PDF form (the sample Mortgage application works still), I think it's because this Default Render does not call the Forms service.



We have tried rebooting the server machine 3 times already, didn't fix it.



The re-starting of WebSphere has been setup as a Windows Service. And there's a problem when we tried to "stop" that Service, it won't die. In order to restart the WebSphere, we had to reboot the machine.



None of these problems were there before they changed the "Domain" of the server machine.



Any idea how to revive the Forms component?



thanks

Jammes