Highlighted

NullPointerException while compiling

Avatar

07-08-2008

Hi All,



Since I am using the AdavancedDataGrid, I am compiling my application with Flex3.0 SDK(3.0.0.477 build),and FlexModule_j2ee(3.0.0.477 build). I am using LCDS 2.5.1 in my application and java version is 1.4.2_08.



I am getting the NullPointerException while compiling with flex webtier module.



08/06 13:59:24 ERROR java.lang.NullPointerException

at flex.webtier.server.j2ee.BaseCompileFilter.getDependenciesFromCompila

tionUnits(BaseCompileFilter.java:215)

at flex.webtier.server.j2ee.IncrementalCompileFilter.compileMxml(Increme

ntalCompileFilter.java:114)

at flex.webtier.server.j2ee.BaseCompileFilter.mxmlToSwf(BaseCompileFilte

r.java:322)

at flex.webtier.server.j2ee.BaseCompileFilter.invoke(BaseCompileFilter.j

ava:60)

at flex.webtier.server.j2ee.RecompileFilter.invoke(RecompileFilter.java:

37)

at flex.webtier.server.j2ee.PathExistsFilter.invoke(PathExistsFilter.jav

a:42)

at flex.webtier.server.j2ee.MxmlServlet.doGet(MxmlServlet.java:163)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:740)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)

at flex.bootstrap.BootstrapServlet.service(BootstrapServlet.java:114)

at weblogic.servlet.internal.ServletStubImpl$ServletInvocationAction.run

(ServletStubImpl.java:1006)

at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubIm

pl.java:419)

at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubIm

pl.java:315)

at weblogic.servlet.internal.WebAppServletContext$ServletInvocationActio

n.run(WebAppServletContext.java:6718)

at weblogic.security.acl.internal.AuthenticatedSubject.doAs(Authenticate

dSubject.java:321)

at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:

121)

at weblogic.servlet.internal.WebAppServletContext.invokeServlet(WebAppSe

rvletContext.java:3764)

at weblogic.servlet.internal.ServletRequestImpl.execute(ServletRequestIm

pl.java:2644)

at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:219)

at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:178)



If any one knows how to resolve the above error, please help me.



Regards,

Munavvar