Multiple LDAP directories ...

Avatar

22-07-2008

Another day, another Livecycle bug ...



I have added a new domain/directory to Livecycle. The synchronization works and the users are correctly added to edcprincipalentity.

Yet whenever i try to logon to workspace i get

"

An error occurred during the operation. Please try again or contact your system administrator for assistance. (ALC-WKS-007-000)

"



The log files show:

"

INFO: ALC-WKS-005-026: Access denied: access permission not assigned to user

"



What kind of access permissions are we talking about here? Also where can i set these?



I remember that i had this problem ages ago and the solution was something very obscure having to do with the unique identifier or so.



Any ideas?

Replies

Avatar

Avatar

chetanm_oct

Avatar

chetanm_oct

chetanm_oct

23-07-2008

You have to assign your users "LiveCycle Workspace User" Role. To grant this role for all the users in your new domain go to<br />Adminui -> Home > Settings > User Management > Users and Groups. There search for a Group "All Principals in <your domain name>". And assign the above role to that group.<br /><br />This should enable your users to log in to workspace

Avatar

23-07-2008

@Chetan

I feel like a moron. I knew i had to assign roles, but for the life of me i couldn't find them anymore.



thank you very much

Avatar

Avatar

srujan816

Avatar

srujan816

srujan816

25-03-2021

What is the solution?

Avatar

Avatar

Kosta_Prokopiu1

Employee

Avatar

Kosta_Prokopiu1

Employee

Kosta_Prokopiu1
Employee

25-03-2021

The solution was that he forgot to assign workspace permissions to these new users coming from the second domain and they therefore were not allowed to log on. Once he created a group, added the workspace user permission to it and then assigned it to all these users they could log on.

Avatar

Avatar

srujan816

Avatar

srujan816

srujan816

25-03-2021

Hi Prokopiu1,

 

I am able to login into workspace but not able to submit the PDF forms?

 When I submitting the form getting the below error

 

DSCError: ComponentID= DSC ErrorCode= 3 MinorCode= 0 Message= Invocation error. ErrorMessage: Invocation error. caused by: ALC-WKS-005-026: Access denied: access permission not assigned to user ""

 

Any idea?

 

Regards,

Srujan

Avatar

Avatar

Kosta_Prokopiu1

Employee

Avatar

Kosta_Prokopiu1

Employee

Kosta_Prokopiu1
Employee

25-03-2021

I can only guess - maybe your users do not have the Services User role which gives permissions Service Invoke and Service Read. Or the service you are submitting to is restricted in access.

Avatar

Avatar

srujan816

Avatar

srujan816

srujan816

25-03-2021

Thanks for reply!

though I tried with Administrator ... forms are not submitting 😞

 

Regards,

Srujan

Avatar

Avatar

Kosta_Prokopiu1

Employee

Avatar

Kosta_Prokopiu1

Employee

Kosta_Prokopiu1
Employee

25-03-2021

If access to the service is restricted it could also exclude the Administrator. Is this the standard submit inside workspace or are you submitting to a custom service? It is very difficult to determine what the problem is from here. Does this happen with all workflows?

Avatar

Avatar

srujan816

Avatar

srujan816

srujan816

25-03-2021

Thanks!

OOTB submit services are using in workspace and this is happening only for PDF forms , all HTML5 forms are submitting successfully. 

 

Regards,

Srujan