Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

java.lang.OutOfMemoryError.Error is null

Not applicable
Hi

While deploying the adobe-livecycle-websphere.ear file iam getting the "java.lang.OutOfMemoryError.Error is null." Can you help in rectifying this error?

We are Thinking that this error is because of heap size, if we are correct please do let us know how to increase the heap size.

We kept Initial Heap Size box as 256 and the Maximum Heap Size box 1024.Also we tried with Maximum Heap Size box as 0(Zero) but we are getting the same error. Please Help us ....
6 Replies
Jasmin_Charbonn
Level 10
Level 10
The heap size that needs to be increased is for the ejbdeploy tool located in %WAS_HOME%\deploytool\itp\ejbdeploy.bat.



You can set it to 512m and that should resolve your problem.



Jasmin
Not applicable
Hi

Thanks a lot... I changed the heap size as you told.It worked out. But Iam getting another error related to version.Actually while installing websphere jdk 1.4 was installed by default but i have jdk1.5 in my system.I am not aware about which jdk that the application server uses. whether the following error is related to this java version? If so what can i do to proceed furthur?



Error generating RMI code: RMIC command failed on project: um-adminui with message:



error: Invalid class file format in E:\IBM\WebSphere\profiles\wp_profile\wstemp\wstemp\app_11448d1eac7\dpl\f1413a65\um-adminui\ejbModule\com\adobe\idp\um\ui\component\AdobeIDP2UI_UMUIComponent.class. The major.minor version '49.0' is too recent for this tool to understand.



error: Class com.adobe.idp.um.ui.component.AdobeIDP2UI_UMUIComponent not found in class com.adobe.idp.um.ui.component.EJSRemoteStatelessAdobeIDP2UI_UMUIComponent_1712f217.



error: Invalid class file format in E:\IBM\WebSphere\profiles\wp_profile\wstemp\wstemp\app_11448d1eac7\dpl\f1413a65\um-adminui\ejbModule\com\adobe\idp\um\ui\component\AdobeIDP2UI_UMUIComponentHome.class. The major.minor version '49.0' is too recent for this tool to understand.



error: Class com.adobe.idp.um.ui.component.AdobeIDP2UI_UMUIComponentHome not found in class com.adobe.idp.um.ui.component.EJSRemoteStatelessAdobeIDP2UI_UMUIComponentHome_1712f217.



4 errors
Jasmin_Charbonn
Level 10
Level 10
Do you have WebSphere 6.1 SP5 installed?

What version do you get when you execute the command %JAVA_HOME%\bin\java -version?



This is coming from the installation document:



Installing WebSphere Application Server

You must install WebSphere Application Server 6.1 for running LiveCycle ES products.



When you run the LiveCycle ES installer, you should run it as the same user.

Installing a Fix Pack to WebSphere 6.1

After you have installed WebSphere 6.1, you must update to Fix Pack 5 or later before you deploy LiveCycle ES.

Refer to the WebSphere support website for access to the WebSphere updates.



Setting the JAVA_HOME and PATH environment variables

As part of your WebSphere installation, a Java SDK was installed. The JAVA_HOME and PATH environment

variables must point to the Java SDK where LiveCycle ES is to be deployed.

➤ To set the JAVA_HOME environment variable (Windows):

1. Select Start > Control Panel > System.

2. Click the Advanced tab.

3. Click Environment Variables.

4. In the System Variables area, click New.

5. Enter JAVA_HOME as the variable name and enter the directory where you installed Java SDK. This directory is where WebSphere installed the Java SDK containing the /bin sub directory.

For example,type the following:

C:\Program Files\IBM\WebSphere\AppServer\java

Note: To verify your JAVA_HOME environment variable, open a command prompt and run the following

command: %JAVA_HOME%\bin\java -version

You should receive a response that begins with java version "1.5.0".



Jasmin
Not applicable
Hi

Thanks. I will install websphere 6.1 application server. And also i am using windows XP service pack 2 operating system. Hope this will meet my requiremnets
Not applicable
hi,



Have to mention Heap size ?, It is mandatory ? I guess default values will override, am I right ....?
Not applicable
ANy one can help me out for auto deployment scripts, I got an script which is in JACL, but jacl is not running on windows OS (tried with wsadmin) received following error. Any commnets .....?



No userID / pass hence sec not enabled.



D:\IBM\WEBSPH~1\APPSER~1\bin>wsadmin -f applicationInstall.jacl



WASX7209I: Connected to process "server1" on node node01 using SOAP connector;

The type of process is: UnManagedProcess

WASX7017E: Exception received while running file "applicationInstall.jacl"; exce

ption information: com.ibm.bsf.BSFException: error while eval'ing Jacl expressio

n:

invalid command name "ÿ?s e t "

while executing

"ÿ?s e t c e l l N a m e firstC e l l "