Expand my Community achievements bar.

Enhance your AEM Assets & Boost Your Development: [AEM Gems | June 19, 2024] Improving the Developer Experience with New APIs and Events

FormDesigner.exe Access violation

Avatar

Former Community Member
I am unable to start up LifeCycle Designer v8.0. I get the following error message.



Unhandled exception at 0x7832c655 in FormDesigner.exe: 0xC0000005: Access violation writing location 0x00000070



I am on a windows XP Professional machine (service pack 2). I have re-installed Adobe and repaired it. I have also installed all the updates to version 8.1.2. I have searched through the forum and have not found a problem like mine. Does anyone have an idea of how to solve the problem?



Thank you in advance for your time.
9 Replies

Avatar

Former Community Member
I'm having the same problem, except I'm running under XP SP3.



In an attempt to understand this, I found several versions of mfc80u.dll on my system, and suspect that LiveCycle is loading the wrong one.



I have versions under Microsoft SQL Server\80 and MSOCache\All Users. Newest item seems to be in \windows\winsxs\x86_microsoft.VC80.MFC_1fc8b3b9a1e18e3b_8.0.50727.1833_x-ww_2fd6f5db (apparently related to Visual Studio 2005)



Acrobat 9 seems to include an older version 8.0.50727.762



I have no idea how to move beyond this info, but hope this helps somebody to come up with a fix.

Avatar

Former Community Member
Yes that seems to be the issue ....we are working through it with Microsoft now.

Avatar

Former Community Member
Here is how I fixed this. I searched c:\windows for mfc8*.dll and found results for files from 2008 in C:\WINDOWS\WinSxS\x86_Microsoft.VC80.MFC_1fc8b3b9a1e18e3b_8.0.50727.1833_x-ww_2fd6f5db. I renamed mfc80.dll to mfc802008.dll and mfc80u.dll to mfc80u2008.dll. Then I copied older dll's from 2005 into this directory with the names mfc80.dll and mfc80u.dll. Now Designer 8.2 launches properly.

Avatar

Level 1

Not sure how you discovered this, but it worked for me too! Thanks!

Avatar

Former Community Member
Thanks!



This helped me a lot. I have read a lot of threads about this problem but none had a solution. I'm using XP and it launches properly now.

Avatar

Former Community Member

worked for me too. Thanks!! I was getting close to giving up on the Designer

Avatar

Level 1

Can you please ellaborate the steps. How did you correct the above problem. Am not able to correct it....

Avatar

Level 1

The Adobe link wouldn't fix ES but the manual instructions worked great from an Acrobat 8 installation. Thank you!!!