Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Email for Task Assigned is not sending to the mailbox

Han_Dao
Level 8
Level 8
Hi,



I am working on the process that need to send an email to the user to notify that there is a task that need to be process but I am not sure why it does not send email when the task is notified in the Workspace. I have enable the user task assigned in LC Admin but it seem to not working and the user could not receive any email when the task is await for process. Do I need to anything to make it work in the process or workbench? Any help would be appreciated.



Thanks much in advance,

Han Dao
17 Replies
Jasmin_Charbonn
Level 10
Level 10
Do you check the settings for the user in WorkSpace (under Preferences)?



Also you need to reboot the app server once you've configured the email settigs in adminui.



Jasmin
Han_Dao
Level 8
Level 8
Hi Jasmin,



I checked the setting for the User in Workspace and the email was enabled. I re-configured the email setting in the adminui and reboot the app server but still could not get the email when the task is assigned. The message only show in the Workspace To Do list. Is there any thing that I need to set in the Workbench, Service? Please advise.



Thanks,

Han Dao
Jasmin_Charbonn
Level 10
Level 10
Do you have email addresses configured for your users?



Did you configured the Home > Services > LiveCycle Process Management ES > Server Settings > Task Notifications -> Task Assignment?



What are the settings for you email server(Home > Services > LiveCycle Process Management ES > Server Settings > Email Settings)? Don't forget to check the "Enable Outgoing Message" checkbox.



Do you have any error in the server.log file?



Jasmin
Han_Dao
Level 8
Level 8
Hi Jasmin,



Answer for your questions:



1)the email was configured to take the email address from LDAP. Do I have I include it in the process?



2) Configured the Home > Services > LiveCycle Process Management ES > Server Settings > Task Notifications -> Task Assignment as bewlow:



-Subject: Task Assignment - Process: @@process-name@@. Task @@taskid@@ has been assigned to you.

- Notification Template: @@instructions@@

Click here to access the task:

http://@@notification-host@@:/workspace/Main.html?taskId=@@taskid@@



3) Email setting:

Home > Services > LiveCycle Process Management ES > Server Settings > Email Settings? Don't forget to check the "Enable Outgoing Message" checkbox.



The Email settings was set to use IRELAY4U with no user name and password is required, the email address is included, and the Enable box was also checked in the setting.



4) Error from the log file:

Caused by: com.adobe.idp.dsc.email.SendMailFailedException: Could not connect to SMTP host: IRELAY4U, port: 25;

nested exception is:

java.net.SocketException: Software caused connection abort: connect

at com.adobe.idp.dsc.email.EmailServiceImpl.sendWithMapOfAttachments(EmailServiceImpl.java:738)

at com.adobe.idp.dsc.email.EmailServiceImpl.sendWithDocument(EmailServiceImpl.java:353)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:79)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)

at java.lang.reflect.Method.invoke(Method.java:618)

at com.adobe.idp.dsc.component.impl.DefaultPOJOInvokerImpl.invoke(DefaultPOJOInvokerImpl.java:118)

... 114 more



Thanks,

Han Dao
Jasmin_Charbonn
Level 10
Level 10
Oh. You're using an email service to send the email. That's something totally different than the built-in notification.



See post http://www.adobeforums.com/webx/.59b75753/1



Jasmin
Han_Dao
Level 8
Level 8
Hi Jasmin,



If I like to use the built-in notification, how do I make it work?



Thanks,

Han Dao
Jasmin_Charbonn
Level 10
Level 10
You shouldn't have to add anything extra to your process.



When you use the User step, and have configured the email settings and the task settings in adminui and configure the preferences in Workspace, you should get an email automatically when new task is assigned to you.



Jasmin
Han_Dao
Level 8
Level 8
Hi Jasmin,



I did not use the email service in my process but I am not sure why it keep calling that email service and did not send email when the task is assigned as I have configured the email setting in the admin as show in the previous post. My process is a simple which is using Get Form, users as 3 different managers to approve for the process.
Jasmin_Charbonn
Level 10
Level 10
Could not connect to SMTP host: IRELAY4U, port: 25 is the error that gets thrown.



Are you sure of that server name. Maybe you need to put the fully qualified name.



Jasmin
pguerett
Level 10
Level 10
If you have VirusScan software on your machine make sure that it is not blocking programmatic access to port 25.
Han_Dao
Level 8
Level 8
I have unblocked the access to the port 25 but still did not get an email when task is assigned. I am still not sure why it is still using email service when I don't have it in my process.



-----Error messages:



Caused by: com.adobe.idp.dsc.email.ConnectionFailedException

at com.adobe.idp.dsc.email.EmailServiceImpl.sendWithMapOfAttachments(EmailServiceImpl.java:736)

at com.adobe.idp.dsc.email.EmailServiceImpl.sendWithDocument(EmailServiceImpl.java:353)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:79)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)

at java.lang.reflect.Method.invoke(Method.java:618)

at com.adobe.idp.dsc.component.impl.DefaultPOJOInvokerImpl.invoke(DefaultPOJOInvokerImpl.java:118)

... 112 more



[1/29/09 14:50:00:443 CST] 0000003e LocalTranCoor E WLTC0017E: Resources rolled back due to setRollbackOnly() being called.

[1/29/09 14:50:00:443 CST] 0000003e NotificationM E Notification could not be delivered to registered subscriber. Reason: Invocation error.

[1/29/09 14:50:00:443 CST] 0000003e NotificationM W Attempting to disable the notification after delivery. Reason ALC-DSC-003-000: com.adobe.idp.dsc.DSCInvocationException: Invocation error.

[1/29/09 14:50:00:490 CST] 0000003d ExceptionUtil E CNTR0020E: EJB threw an unexpected (non-declared) exception during invocation of method "doSupports" on bean "BeanId(Adobe LiveCycle Main 8.2#adobe-dscf.jar#EjbTransactionCMTAdapter, null)". Exception data: ALC-DSC-003-000: com.adobe.idp.dsc.DSCInvocationException: Invocation error.



-----End----



Any advise would be appreciated.



Thanks again,

Han Dao
HowardTreisman
Level 9
Level 9
Hi Han

To debug your mail connectivity, one way is to download a mail client (such as http://www.mozilla.com/en-US/thunderbird/) and install it on your server. It MUST be the same server as LiveCycle is installed on.



Then try to configure ThunderBird to connect to your mail server and send an email. That should hopefully be an easy way to tell if you've got your server names, authentication, etc, set up correctly.



Howard

http://www.avoka.com
richruiz
Level 3
Level 3
I am experiencing the same problem. Test the connection settings using...



http://www.blat.net/



I get no erros in the log file.
richruiz
Level 3
Level 3
FYI on this...



Adobe support has checked all the settings and cannot find anything wrong. I'd like to find a way to debug the sending of the email via JBOSS logging. Any ideas?
Jasmin_Charbonn
Level 10
Level 10
Did you try sending emails with a mail client on the LC machine like Howard suggested?



Jasmin
Balaji_Gurumurt
Level 2
Level 2

hi,

     I use an email service in my ES2 workflow. I have still configured the credentials but still am facing the below error :

ALC-DSC-003-000: com.adobe.idp.dsc.DSCInvocationException: Invocation error.
at com.adobe.idp.dsc.component.impl.DefaultPOJOInvokerImpl.invoke(DefaultPOJOInvokerImpl.java:152)
at com.adobe.idp.dsc.interceptor.impl.InvocationInterceptor.intercept(InvocationInterceptor.java:140)
at com.adobe.idp.dsc.interceptor.impl.RequestInterceptorChainImpl.proceed(RequestInterceptorChainImpl.java:60)
at com.adobe.idp.dsc.interceptor.impl.DocumentPassivationInterceptor.intercept(DocumentPassivationInterceptor.java:53)

I couldn't get why it is .. Need HELP ....!

thanx

Balaji

Jasmin_Charbonn
Level 10
Level 10

Did you also configured the SMTP server, protocol, etc.

Can you post your config settings?

Jasmin