Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Displaying HTTPService returned data in a dataGrid

Arthur-Lockman
Level 1
Level 1
Hello! im new to flex and i have a question that i am hoping
someone can answer. I have a flex app that i am building that needs
to display a list of dynamic images, preferably with icons. I've
built the Title list, but i don't know how to connect the
HTTPService data to the list. the HTTPService is returning XML
data, so it must be easy. but, as i said, Im really new. Please
Help Me!!
0 Replies
Arthur-Lockman
Level 1
Level 1
thanks, but that isn't really what i need. I can do that, but
i need to display images instead of text. Thanks for the help
anyways!
Michael_Borbor
Level 3
Level 3
The link I gave you teaches you how to make a remote call you
just need to add an image control to the app and you're done.

How do you know where the images are located?

Arthur-Lockman
Level 1
Level 1
I know by a parameter that the HTTPService sends back to me
that contains the image URL. However, the image URL is not in the
source folder in the app. It is located at a remote location, so
the url takes the form of "
http://www.test.net/09/image.jpg".
Maybe i am formatting the image wrong, because I am still getting
no result in the data grid. This is what i am getting back from the
HTTPService:



<images>

<image>

<image_name></image_name>

<image_url></image_url>

<keywords></keywords>

</image>

</images>



and this is my data grid:



<mx:DataGrid x="10" y="10" width="640" height="140"
dataProvider="{imageReturn.lastResult.images}"
id="communityImages">

<mx:columns>

<mx:DataGridColumn headerText="Image" >

<mx:itemRenderer>

<mx:Component>

<mx:Image source="{image.image_url}"/>

</mx:Component>

</mx:itemRenderer>

</mx:DataGridColumn>

<mx:DataGridColumn headerText="Name"
dataField="{image.image_name}"/>

<mx:DataGridColumn headerText="Keywords"
dataField="{image.keywords}" visible="false" />

</mx:columns>

</mx:DataGrid>



maybe I'm formatting it wrong. I'm not sure. Help Me with
this and my problems will be solved.