Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Change to earlier target version and question on combs

Jono_Moore
Level 10
Level 10
Is there a way to change the target version of a form without rebuilding it?



I built some forms targeted at Acrobat 8 because of features used (combs mostly) but the client needs Acrobat 7 compliance (government IT policy).



Also, I tried out the combs in Reader 7 and they seemed to work ok - does anyone know why they're not supposed to be version 7 compliant?
9 Replies
pguerett
Level 10
Level 10
Under the File Menu/Form Properties in the Defaults Tab you can set a target version. If you have added features to the form that are beyond this target version you will see warnings in the Warnings/Report palette. To activate this palette click on Report under the Window menu.



I am going from memory here so the story may not be 100% correct but you will get the idea.



The UI to add the comb to the form was added in Designer 8. The xfa grammar (the part that describes the comb in the xml template) has been available from the beginning. So the interpretation of the grammar to the comb is OK. Previous to version 8 of Designer you had to code the xml by hand (hence the term it is not supported). Make sure you test it but I am sure that it will behave the way you want.
Jono_Moore
Level 10
Level 10
> Under the File Menu/Form Properties in the Defaults Tab you can set a target version.



I tried that but it won't let me pick an earlier version now. I had previously changed it to version 8 (to get rid of the error messages) before I knew that we needed version 7 compatibility.



Thanks for the info on the comb compatibility.
pguerett
Level 10
Level 10
Did you create the PDF by importing from another format? If you created an image PDF and laid fields on top tha would explain it as version 8 is the minimum version that can support that format.
Jono_Moore
Level 10
Level 10
Hmm...interesting. Yes, it created with PDF as artwork underneath...but the target version is currently set to 6.0.2 or later. It was after I'd set the version to 8 that it wouldn't then let me set it to an earlier version.



And it seems to work ok in Reader 7.



I just tried a test setting the target version to 8.1 - as long as I don't close and reopen the file I can change the target version back. But if I close and open the file then I can't change back from 8.1 to anything else.
pguerett
Level 10
Level 10
Sounds like a bug .....you should report it to support.
Jono_Moore
Level 10
Level 10
Are you sure about the version support for pdf artwork? I can't seem to find any reference about it.



Which is the bug I should report...that I'm able to use pdf artwork with earlier versions or not being able to switch to an earlier version in the defaults tab? 🙂
pguerett
Level 10
Level 10
Not being able to switch on the tabs.
Jono_Moore
Level 10
Level 10
Can you point me to where we report bugs? Can't seem to find anything...
pguerett
Level 10
Level 10
On the Devnet site there is a link that allows you to report a bug (I believe).