Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Status code 404 for wsk list command

Avatar

Level 2

We have created a property in Adobe I/O runtime and got the namespace vale. But when we are trying to run the below command getting the HTTP Status code 404. Could you please help here.

SahithiMalyala_0-1599467433486.png

 

3 Replies

Avatar

Level 2

Hi SahithiMalyala,

Did you deploy a package and actions to the environment? Does it have something that it can list?

 

Regards,

Avatar

Level 2

Hi 

We are not even able to deploy the triggers every WSK command is failing with the same error messsage. I think the wsk is being pointed to default namespace but not the one defined in the valid namespaces

Avatar

Level 2

What version of wsk cli are you using? Can you try and update to the latest?

Avatar

Level 1

Hi @SahithiMalyala ,

 

Can you describe how you initially created the property "288455-boilingtancoyote"? 
How did you attempt to deploy the newly created package(s) and/or action(s)? 
Can you confirm your local .wskprops are set correctly to correspond with OpenWhisk on Adobe IO Runtime? 

 

Kind regards, Marijn

Avatar

Level 2

Hi Marijn, Below are the steps we followed

1. We created a project in Adobe Console with Runtime enabled.

2. There is a name space that is created by default by Adobe runtime and we received the Details from Runtime.

3. We used the API Endpoint, Secret from the project json we downloaded from the project.

4. Using WSK command we have updated the property of APIHOST and Authe information

 

Could you please help us fix the issue.

Avatar

Employee
+1 to what Marijn said, please verify `.wskprops` file in your home folder to assure that the Runtime credentials are set correctly. And make sure "APIHOST=adobeioruntime.net"