Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

404 Error while Selecting Integration

Avatar

Avatar
Contributor
Level 4
rajneesh_gautam
Level 4

Likes

62 likes

Total Posts

66 posts

Correct Reply

12 solutions
Top badges earned
Contributor
Ignite 5
Ignite 3
Ignite 1
Validate 1
View profile

Avatar
Contributor
Level 4
rajneesh_gautam
Level 4

Likes

62 likes

Total Posts

66 posts

Correct Reply

12 solutions
Top badges earned
Contributor
Ignite 5
Ignite 3
Ignite 1
Validate 1
View profile
rajneesh_gautam
Level 4

12-12-2019

Hi there,

 

When I run the command

aio console:list-integrations

I can see my Adobe IO Integration listed successfully. However, when I run

aio console:select-integration number1_number2

I get following error:

 

Error: Cannot retrieve integration: https://api.adobe.io/runtime/admin/namespaces/number1/number2 (404 Not Found)

 

 

Can someone help me understand what I am missing? When I go to Adobe IO console, I can access the integration successfully.

 

Thanks in advance,

 

Regards,

Rajneesh

 

Accepted Solutions (0)

Answers (4)

Answers (4)

Avatar

Avatar
Validate 1
Level 1
norbertb5623275
Level 1

Likes

4 likes

Total Posts

10 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
View profile

Avatar
Validate 1
Level 1
norbertb5623275
Level 1

Likes

4 likes

Total Posts

10 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
View profile
norbertb5623275
Level 1

30-01-2020

Hi all,

Did you find a solution on this ? We are facing the same issue ?

Regards,
Norbert

Avatar

Avatar
Ignite 5
Employee
Mihai_Corlan
Employee

Likes

6 likes

Total Posts

29 posts

Correct Reply

4 solutions
Top badges earned
Ignite 5
Ignite 3
Ignite 1
Establish
Give Back
View profile

Avatar
Ignite 5
Employee
Mihai_Corlan
Employee

Likes

6 likes

Total Posts

29 posts

Correct Reply

4 solutions
Top badges earned
Ignite 5
Ignite 3
Ignite 1
Establish
Give Back
View profile
Mihai_Corlan
Employee

24-01-2020

Hi Rajneesh,

 

This flow is enabled only for customers who have acquired the Runtime add-on SKU - this unlocks support for Runtime in I/O Console. If you have received namespaces from our team, then you will need to follow the docs and look for the section that points to how to configure the CLI using the .wskprops file (this is what we gave you).

 

Cheers,

Mihai

Avatar

Avatar
Contributor
Level 4
rajneesh_gautam
Level 4

Likes

62 likes

Total Posts

66 posts

Correct Reply

12 solutions
Top badges earned
Contributor
Ignite 5
Ignite 3
Ignite 1
Validate 1
View profile

Avatar
Contributor
Level 4
rajneesh_gautam
Level 4

Likes

62 likes

Total Posts

66 posts

Correct Reply

12 solutions
Top badges earned
Contributor
Ignite 5
Ignite 3
Ignite 1
Validate 1
View profile
rajneesh_gautam
Level 4

12-12-2019

Hi Mihai, after several attempts to get this work, I am still getting 404 error.

 

Steps I had to take (which dont seem to be documented so need to understand what is wrong):

1. Downloaded Openshisk on my Mac and extracted the WSK executable.

2. Added the folder to PATH.

3. Created an IO Integration with following services:

- IO Management API

- IO Events

4. Created a config.json file with details of the IO integration. Here're the contents:

{

  "client_id": "",

  "client_secret": "",

  "jwt_payload": {

   "exp": 1575648943,

    "iss": "",

    "sub": "@techacct.adobe.com",

    "https://ims-na1.adobelogin.com/s/ent_adobeio_sdk": true,

    "https://ims-na1.adobelogin.com/s/event_receiver_api": true,

    "aud": ""

},

  "token_exchange_url": "https://ims-na1.adobelogin.com/ims/exchange/jwt",

  "console_get_orgs_url":"https://api.adobe.io/console/organizations",

  "console_get_namespaces_url":"https://api.adobe.io/runtime/admin/namespaces/"

}

5. Created .wskprops file in the same folder with the content received from Adobe team

6. Ran command: aio config:set jwt-auth config.json --file --json
7. Ran command: aio config:set jwt-auth.jwt_private_key <path of private key I used for Adobe IO Integration>

8. Ran command wsk property set --apihost adobeioruntime.net  --auth  <Auth key provided by Adobe> namespace  <Custom Namespace provided by Adobe>

9. Ran command: aio console:list-integrations

10. Ran command: aio console:select-integration <Integration-id from the list>

 

 

Will appreciate any help here,

 

Regards,

Rajneesh

 

Avatar

Avatar
Contributor
Level 4
rajneesh_gautam
Level 4

Likes

62 likes

Total Posts

66 posts

Correct Reply

12 solutions
Top badges earned
Contributor
Ignite 5
Ignite 3
Ignite 1
Validate 1
View profile

Avatar
Contributor
Level 4
rajneesh_gautam
Level 4

Likes

62 likes

Total Posts

66 posts

Correct Reply

12 solutions
Top badges earned
Contributor
Ignite 5
Ignite 3
Ignite 1
Validate 1
View profile
rajneesh_gautam
Level 4

12-12-2019

hi Michael, thanks for this. Upon trying to following command, I am getting error_code 401013 error, with message = Oauth token is not valid.

 

curl -H "X-Api-Key: <Your Client ID>" -H "x-ims-org-id: <Your Org ID>"  -H "Authorization: Bearer  <Auth Token>" -H "accept: application/json" https://api.adobe.io/runtime/admin/namespaces/<NUMBER>/<NUMBER>

 

Any idea why it might be happening?