Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Sudden latency between Analytics Triggers and Journal

jgrubbs
Level 2
Level 2

Hello all,

 

We've been relying on Analytics Triggers and the Journaling API in Adobe IO to collect important data. It has been going extremely well for over a month, providing us with a valuable bit of data in something close to real time.

 

However over the last day or two, the Journal endpoint continues to respond with "204 No Content". I can see that the Trigger events are still being generated according to the Triggers UI (in "Activation"), but the Journal doesn't seem to be getting them, or it isn't allowing me to pull them

 

I'm using the appropriate endpoint URL and path specified by the "Next" attribute. Even if I request "latest=true", I get nothing, and again the "Next" attribute points to the same URL and "since" parameter...

 

Is there some kind of traffic jam going on? I have a ticket open this morning with Client Care, but I fear the rep I'm interacting with doesn't have a grasp of what I'm describing. Despite my detailed explanation, with URLs and all, they're asking for "screenshots" and a step-by-step explanation. I'm not sure how to snap a photo of a data pipeline 🙂

 

I guess my question is: Is anyone else noting the same kind of latency? Is there some kind of back-end trouble at Adobe that needs to be fixed?

 

Thank you all

 

1 Accepted Solution
shikhartanwar
Correct answer by
Employee
Employee

There is definitely no latency at our side for the Journaling API, but to be doubly sure, could you help us with the IMS organization id and the journaling endpoint for debugging? I can go through our Splunk logs and verify if things are working correctly.

View solution in original post

5 Replies
shikhartanwar
Correct answer by
Employee
Employee

There is definitely no latency at our side for the Journaling API, but to be doubly sure, could you help us with the IMS organization id and the journaling endpoint for debugging? I can go through our Splunk logs and verify if things are working correctly.

View solution in original post

jgrubbs
Level 2
Level 2
Thank you for the response. I really hope you can help. I sent the IMS ID and endpoint in a private message to you. Fingers crossed!
shikhartanwar
Employee
Employee
Thanks for sending the details @jgrubbs. We did have an issue at our end in processing triggers. The problem is now resolved. Could you please confirm if it's fixed at your end also?
jgrubbs
Level 2
Level 2
Wow... So I have a cron job that runs every hour. The journal has been returining 204 No Content for nearly 2 days but now as of a few minutes ago, it returned 800+ records 🙂