Uploading "plugin file" is not working

Avatar

Avatar
Validate 1
Level 1
Ali_P
Level 1

Like

1 like

Total Posts

6 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile

Avatar
Validate 1
Level 1
Ali_P
Level 1

Like

1 like

Total Posts

6 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile
Ali_P
Level 1

23-04-2021

I have been trying to upload a new update for an Adobe XD plugin, for the last two days.
When it gets to the part where you add "plugin file," after adding the file, the progress wheel next to the file turns and turns, and nothing happens.
I tried with multiple machines on different connections; the outcome is the same.

 

 

Screen Shot 2021-04-23 at 12.00.42 PM.png

View Entire Topic

Avatar

Avatar
Affirm 10
Employee
devconsole
Employee

Likes

8 likes

Total Posts

55 posts

Correct reply

11 solutions
Top badges earned
Affirm 10
Ignite 1
Give Back
Boost 5
Boost 3
View profile

Avatar
Affirm 10
Employee
devconsole
Employee

Likes

8 likes

Total Posts

55 posts

Correct reply

11 solutions
Top badges earned
Affirm 10
Ignite 1
Give Back
Boost 5
Boost 3
View profile
devconsole
Employee

27-04-2021

Quick update: we believe that something is incorrect in your manifest file and that's causing the upload to fail. Related to this, we'll be making an update on our end to show why the upload actually fails as opposed to just spinning.

@Ali_P & @thx1138 please make sure that you are using the manifest version that is part of the starter pack on the Dev Console. If you are comfortable, please send me your manifest via DM and engineering can check what needs to change

Ali_P
You are right. Even though I changed the manifest.json a few times, it didn't make any difference, but for whatever reason, it did go through when I made a few other changes today. I have successfully submitted the plugin update. Thank you!
thx1138

I am still having issues. The only difference I see in my manifest from the starter project is that I have nested menu items and I have main property value defined. 

thx1138

I'll keep checking for the changes. As of today I'm still having issues. If you don't mind could you update this thread when the IO console has been updated?

devconsole
@thx1138 we just deployed a change that will provide better error messages during upload issues. hopefully that will provide some details on why the upload is failing
thx1138
Hi great. I just tried it and it does give a message: "Plugin file your_plugin.xdx Plugin file has failed extraction. Please see our packaging documentation for details"
thx1138

Hi great. I just tried it and it does give a message now. This is much better.

 

The message:

 

Plugin file your_plugin.xdx Plugin file has failed extraction. Please see our packaging documentation for details.

 

I'm a bit stuck because I've read through the documentation. 

 

Can you expand on what I might be missing?

Can I send you my xdx?

Can you add a link to the "packaging documentation" and "manifest documentation"? 

 

I think the only thing I've changed in the manifest is the version number. 

Ali_P
@thx1138 Try with a fresh Manifest and import your info one by one; check each one to make sure you do not have some weird character in it. Try to stay away from the eerie ASCII characters. I would replace the title and description with a simple text, like a one-word "test," then upload and test to see when it goes through and find which one is causing the issue. I know you might have to keep doing it till the cows come home, but this is the best we've got.
thx1138

I think I got it figured out.

 

I have a root folder (alongside my main.js and others) called "addons" and in that folder is a blank file called "tagnames.txt".

 

When I compress the project into an xdx and include that folder it breaks. If I exclude that folder it works. 🤔 

 

BTW The error for me, according to the IO console is: 

 

Plugin file has failed extraction. Please see our packaging documentation for details

 

It is not: 

 

Plugin manifest file could not be parsed. Please see our manifest file documentation for requirements

 

 

lucianmoldovan
For anyone still encountering this issue: please make sure there is no file of 0 bytes size (empty file) inside your plugin.
thx1138
Are the error messages updated yet? I tried to upload again (with empty file) and it failed with the same generic error message