Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Error: Credential with service type already exists in the workspace

Darren_Bowers
Community Advisor
Community Advisor

I am trying to create two projects for Adobe Campaign Classic to Analytics Triggers using this guide:  https://experienceleague.adobe.com/docs/campaign-classic/using/integrating-with-adobe-experience-clo...

I have two servers (Stage & Prod) that use two different Analytics report suites via different Analytics Product Profiles. I have configured the Stage project with an Analytics API / JWT auth no problems and it is working.

When I try to create a second Analytics API with JWT credential in the second project, and try to generate a new keypair I get the error "Credential with service type already exists in the workspace"

Then I tried to upload the public key from the Stage project and it just hangs and does nothing except spin the wait icon.

How do you create a second project with unique keypair so I can keep my JWT auth mechanisms separate?

Thanks

Darren

Analytics API jwt Project
1 Accepted Solution
Darren_Bowers
Correct answer by
Community Advisor
Community Advisor

We found a fix for the below issue: delete the project and re-create it.

It's likely that the issue was caused by the old Project name containing dashes. When I recreated the Project it wouldn't allow dashes as valid characters. There must have been a code change during creation of the project and configuration.

Thanks @devconsole

Darren

View solution in original post

1 Reply
Darren_Bowers
Correct answer by
Community Advisor
Community Advisor

We found a fix for the below issue: delete the project and re-create it.

It's likely that the issue was caused by the old Project name containing dashes. When I recreated the Project it wouldn't allow dashes as valid characters. There must have been a code change during creation of the project and configuration.

Thanks @devconsole

Darren

View solution in original post