Adobe launch - Android SDK - Launch, First Launch, crashes & launch number not captured

Avatar

Avatar
Validate 1
Level 1
padmaa17619878
Level 1

Likes

0 likes

Total Posts

9 posts

Correct reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
padmaa17619878
Level 1

Likes

0 likes

Total Posts

9 posts

Correct reply

0 solutions
Top badges earned
Validate 1
View profile
padmaa17619878
Level 1

27-12-2020

Hello,

Recently moved from mobile SDK to launch. Two strange issues were observed:

a) the following life cycle metrics are not captured 

1. Install - First Launches,Install Date

2. Upgrade - Upgrades, Launches since last upgrade, Days since last upgrade

3. Crash - Crashes

4. Launch - Launches, Launch Number, Days since first use, etc

 

but Application Context & device Info are captured.

 

b) Unique visitor count increases every time when the app gets launched. New visitor id is generated.

 

what could be the reason? anyone can guide?

 

 

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Affirm 3
Employee
emdobrin
Employee

Likes

10 likes

Total Posts

14 posts

Correct reply

4 solutions
Top badges earned
Affirm 3
Boost 10
Boost 5
Boost 3
Boost 1
View profile

Avatar
Affirm 3
Employee
emdobrin
Employee

Likes

10 likes

Total Posts

14 posts

Correct reply

4 solutions
Top badges earned
Affirm 3
Boost 10
Boost 5
Boost 3
Boost 1
View profile
emdobrin
Employee

29-12-2020

Hi @padmaa17619878 ,

 
Thanks for reaching out. 
Can you confirm that the previous version of the Mobile SDK (adobeMobileLibrary) has been removed from your app dependencies and that you are using only the AEP SDK extensions as per the Launch Install instructions? After migration, only the new version of the SDK should be installed in your app.
 
For the Lifecycle metrics, make sure you implemented the Lifecycle API calls for your app, this documentation can help with that https://aep-sdks.gitbook.io/docs/resources/upgrading-to-aep/manual-lifecycle-implementation.
 
Let us know if this fixed your issues.
 
Emilia Dobrin
Computer Scientist
 

Answers (1)

Answers (1)

Avatar

Avatar
Boost 1
Level 1
floriangol
Level 1

Like

1 like

Total Posts

1 post

Correct reply

0 solutions
Top badges earned
Boost 1
View profile

Avatar
Boost 1
Level 1
floriangol
Level 1

Like

1 like

Total Posts

1 post

Correct reply

0 solutions
Top badges earned
Boost 1
View profile
floriangol
Level 1

04-01-2021

I would propose you to search for "ADBMobile" and delete everything related to that. And also check that the json config file for the old sdk is completely removed. The configuration is now coming from adobe launch completely.

 

Best regards

Florian