Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Mark Solution

This conversation has been locked.

wrong succession of actions in published rule

Avatar

Avatar
Validate 1
Level 2
frankr83800809
Level 2

Likes

5 likes

Total Posts

3 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile

Avatar
Validate 1
Level 2
frankr83800809
Level 2

Likes

5 likes

Total Posts

3 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 1
View profile
frankr83800809
Level 2

04-07-2018

Hi,

when configuring a new rule to fire a tracking request I set three actions:

1. Set Variables

2. Send Beacon

3. Clear Variables

After testing I see an Adobe Analytics request without any props or evars.

And when looking at the published rule it looks like:

1. Send Beacon

2. Set Variables

3. Clear Variables

How can I get this right?

Best,
Frank

View Entire Topic

Avatar

Avatar
Contributor
Level 4
Reyhan_Sadaka
Level 4

Likes

51 likes

Total Posts

16 posts

Correct Reply

1 solution
Top badges earned
Contributor
Validate 1
Shape 1
Give Back
Boost 50
View profile

Avatar
Contributor
Level 4
Reyhan_Sadaka
Level 4

Likes

51 likes

Total Posts

16 posts

Correct Reply

1 solution
Top badges earned
Contributor
Validate 1
Shape 1
Give Back
Boost 50
View profile
Reyhan_Sadaka
Level 4

06-07-2018

I just tested in my instance, taking a rule that had been working. I added some values to the "Set Variables" call and I'm now seeing the same issue where "Send Beacon" is happening before "Set Variables". I did not change the ordering at all.

This seems like it's an issue with Launch itself - something in the compiling and building of the rules?