Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Version compare not working

thefoxman80
Level 1
Level 1

After the recent Launch changes to version control (which are very welcomed) it seems that the compare takes into consideration minor formatting changes as well so many times everything is highlighted as changed.  I never saw this behavior before. Is this a known bug?

1 Accepted Solution
yuhuisg
Correct answer by
Community Advisor
Community Advisor

Every time you press "Save" in a Rule or Data Element, Launch saves a new revision of that asset. (You'll notice the revision number getting bumped with each "Save".) This behaviour has been there since day 1 of Launch, as far as I know. Version control gets its information from these revisions.

So if you're seeing minor formatting changes between revisions, it's most likely because you keep saving your rules/data elements.

View solution in original post

2 Replies
yuhuisg
Correct answer by
Community Advisor
Community Advisor

Every time you press "Save" in a Rule or Data Element, Launch saves a new revision of that asset. (You'll notice the revision number getting bumped with each "Save".) This behaviour has been there since day 1 of Launch, as far as I know. Version control gets its information from these revisions.

So if you're seeing minor formatting changes between revisions, it's most likely because you keep saving your rules/data elements.

View solution in original post

thefoxman80
Level 1
Level 1
THis doesn't address the bug. Before it was not highlighting simple changes in format. Now it is.