Update Analytics Extension warning with every library build

thomas_amsler

24-10-2018

Each time I make a small change in some rules, update my library and trigger a build for development I get the warning that the Analytics Extension needs an update and I need to confirm that I want to apply it. I did this now at least 5 times, shouldn't this be saved with the revision of the Analytics Extension?

Why do I need to "apply" these changes every time I build the library?

Accepted Solutions (1)

Accepted Solutions (1)

thebenrobb

Employee

25-10-2018

OK, that sounds like our dependency checker is running amok.  I'd appreciate a private message with the URL to the property and I'll log a bug to have the team take a look.

Answers (5)

Answers (5)

MHicken

Employee

19-11-2018

Chances are good that it won't be an issue, but below are links to the release notes for both Core and Analytics. If you think the updates may affect your rules, it would be worth applying the work-around to them.

Core Extension Release Notes - Launch, by Adobe

Adobe Analytics Release Notes - Launch, by Adobe

thomas_amsler

19-11-2018

Ok, thanks for the info, but now there was also an update on Core and I would need to touch every single rule I have. Is there any known problem if I don't do it?

MHicken

Employee

16-11-2018

We've identified the source of the issue and will work on the fix.

Until we can release a fix, the workaround is to determine which of your rules were saved using an old version of any extension. You can do this by eliminating them from your Library one at a time, until you are no longer prompted on save.

For each of those rules, make ANY edit the individual rule components of that rule. Changing their name will suffice. This will update them to use the latest versions of the extensions they require.

If this workaround doesn't fix the issue for you, please let us know!

thomas_amsler

24-10-2018

It doesn't actually matter, where I make a change, but when I am inside Edit Library and click the Save and build button, I get the warning:

Missing Required Extensions

The following extensions will be added because they are required by resources in this library.

And the button is called: Apply Updates and Continue

thebenrobb

Employee

24-10-2018

Can you be more specific?

Are you making changes inside an actual rule? Or inside the Analytics extension configuration screen (global variables for example)?  And the warning you're asking about is when you are inside the Edit Library screen when you push the Save button?