Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Unable to send data to AEP using Web SDK

bitunsen
Level 2
Level 2

Hi Team,

 

I am new to the AEP Web SDK and trying to explore the capabilities of the Web SDK just by creating a static web page in my local desktop. What I had done so far is:

  • Created a XDM (ExperienecEvent) in AEP
  • Created a dataset for the XDM I had defined in AEP
  • Created a DataStream in Adobe Launch
    • Enabled AEP to send data to AEP
    • Mapped the dataset (created above)
  • Created a Property under "Tags" in Adobe Launch
    • Installed and configured AEP Web SDK, Cloud ID Service as Extensions
      • Passed my ORG ID to Web SDK while configuring and mentioned "edge.adobedc.net" as Edge domain.
    • Created some local storage variables as Data Elements
    • Created a data element of type XDM object and mapped the data elements to the respective XDM fields
    • Created rules for a particular Page Type to  send Event of type "commerce.productViews"
  • Created a Library and published it to Development environment
  • In the static web page, added the script for Development environment along with other local storage elements whose values will be mapped to the XDM.
    • Added a onload script in the body of the static page which is calling the _satellite.track('productview') after building the dataLayer.

  After doing all these, when I am opening the static page in any browser, I am getting the below error:

AEP_Launch_Issue.jpg

 

I had checked the launch-28a5d85e2c18-development.min.js which was generated by Web SDK and verified that my ORG ID is exactly same. I am not sure what is wrong here. If anyone of you can point me out what is wrong here, that will be really great.

 

Thanks a lot in advance. 

2 Replies
bitunsen
Level 2
Level 2

I am able to solve this by doing the following:

  • Converted the single static page into a static Web Application and deployed the application in JBoss EAP application server.

I am sure if I had used Tomcat, then as well it would have worked.

Jayakrish
Level 4
Level 4

Hi @bitunsen ,

 

I have written a blog on this topic. You can have a look on the same and make sure that you have covered all the steps to get your alloy beacon.

 

https://jayakrishnaap91.medium.com/adobe-analytics-implementation-using-alloy-js-aep-web-sdk-through...

 

Thank you,

Jay.