Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Rules firing, page view analytics on some pages but not others (rule still fires and sets vars just fine)

edwardb44196902
Level 2
Level 2

We have global rules setting variables on the site, some pages are displaying the page view analytics and others are not. When I check, the rules are firing fine, launch is detected, I check the variables and it is setting correctly but no page views. I'm really confused on this, any ideas or help would be greatly appreciated as to what I should try next.

1 Accepted Solution
ishans52004352
Correct answer by
Employee
Employee

Hi @edwardb44196902 ,

There would be some condition, etc. either in Rules or Analytics extension setting that is preventing the firing of server call on those pages. Can you please check? Is there anything extra (Rules or something) that is firing on the culprit pages and not firing on other working pages?

We will need to check on these possibilities. You may want to send it to Client Care for the detailed investigation. 

Thank you!

View solution in original post

8 Replies
ishans52004352
Correct answer by
Employee
Employee

Hi @edwardb44196902 ,

There would be some condition, etc. either in Rules or Analytics extension setting that is preventing the firing of server call on those pages. Can you please check? Is there anything extra (Rules or something) that is firing on the culprit pages and not firing on other working pages?

We will need to check on these possibilities. You may want to send it to Client Care for the detailed investigation. 

Thank you!

View solution in original post

edwardb44196902
Level 2
Level 2

hello @ishans52004352  

 

We currently have only 3 rules fire, 1 sets the page analytics, the other rule is a custom code rule which just gives a naming convention to anchor tags and the third sends the beacon. will reach out to client care perhaps about this. just strange how some pages fire the page views and others don't. thank you for your reply. hoping to figure out the solution to this. the rules meet the conditions where the pages are not firing page view analytics and i've checked the markup on the script and didn't see anything that would prevent it from working.

edwardb44196902
Level 2
Level 2
hello @ishans52004352 , i did have 1 rule that did both, set vars and send the beacon, still no luck getting the page analytics to display on all pages. just specific few.
edwardb44196902
Level 2
Level 2
everything is working as expected now. sorry for a late reply. thank you!
ishans52004352
Employee
Employee

Sure, @edwardb44196902 .

Just a thought - why not load Analytics variables and send the beacon as part of the same rule instead of multiple rules?

Thanks!

jantzen_belliston-Adobe
Level 10
Level 10
Do any of the answers below answer your initial question? If so, can you select one of them as the correct answer? If none of the answers already provided answer your question, can you provide additional information to better help the community solve your question?
jantzen_belliston-Adobe
Level 10
Level 10
Were you able to solve this issue? If so, would you mind posting the solution so others that find this thread have the answer?