Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Not able to create any library in Event forwarding

Avatar

Level 3

Hi there,

 

I was started a POC around event forwarding. When I was trying to create a new library in event forwarding property, it is failing and giving some error. Here I'm sharing the error details. Let me know anyone faced similar issues earlier, 

Details:

{
  "lensCode": "generalError",
  "dateTime": "Tue Sep 13 2022 14:27:49 GMT+0530 (India Standard Time)",
  "message": "An unknown error has occurred.",
  "urlAtTimeOfError": "https://experience.adobe.com/solutions/reactor-lens/eventForwarding/companies/COa60cd08e5d294f73bd8a289afbffd111/properties/PR450910d6b5d34c7695edc8018d4fc0f8/publishing/new?reactor-lens_version=prod20220906165305",
  "networkResponse": {
    "headers": {
      "cache-control": "no-cache",
      "content-type": "application/vnd.api+json"
    },
    "status": 409,
    "statusText": "Conflict",
    "type": "cors",
    "url": "https://reactor.adobe.io/properties/PR450910d6b5d34c7695edc8018d4fc0f8/libraries",
    "textBody": "{\"errors\":[{\"id\":\"b2517afd-3e66-46c3-9033-11a8b226cbf5\",\"code\":\"invalid-status\",\"title\":\"Invalid status\",\"detail\":\"cannot create a library with an environment having the failed status\",\"meta\":{\"request_id\":\"nMUIgIUFsXfj5sTh9eEqBjuIotNdqe4k\"},\"source\":{\"pointer\":\"/data/attributes/status\"}}]}",
    "body": {
      "errors": [
        {
          "id": "b2517afd-3e66-46c3-9033-11a8b226cbf5",
          "code": "invalid-status",
          "title": "Invalid status",
          "detail": "cannot create a library with an environment having the failed status",
          "meta": {
            "request_id": "nMUIgIUFsXfj5sTh9eEqBjuIotNdqe4k"
          },
          "source": {
            "pointer": "/data/attributes/status"
          }
        }
      ]
    }
  }
}

Thanks in advance

1 Accepted Solution

Avatar

Correct answer by
Employee

Hi Paul,

You can see from the error that the core of the issue is the environment you're adding to the library had a failed status.  This should now be resolved for your property. 

View solution in original post

6 Replies

Avatar

Level 1

Same problem here, also setting up a POC.

I've followed the same steps as if I was creating a Library in Launch, but receive the same error. 

1. Publishing Flow > Add Library

2. Give it a name and select Development as the Environment

3. Click Save

4. Receive error.

 

Anyone from Adobe able to solve this, its stopping us from testing and deploying.

 

Thanks,

Avatar

Employee

Hi,  can you give me a bit more info here,  like your Org Id or Org Name,  we can look into why the environment creation is not successful.  (this is the root cause of the library creation failing)  

 

Or an output of the error would give us all we need as well. 

 

Avatar

Level 1

Hi Jason 🙂 I can create a lib fine, its when I try to assign it to a env is when I get the error. I tried via the UI and the reactor api using postman, but the same issue.

 

Thanks!

 

An unknown error has occurred.

Details: 
{
  "lensCode": "generalError",
  "dateTime": "Thu Oct 06 2022 07:54:12 GMT+0800 (Australian Western Standard Time)",
  "message": "An unknown error has occurred.",
  "urlAtTimeOfError": "https://experience.adobe.com/solutions/reactor-lens/eventForwarding/companies/COca49f01decef444a8eaa09d707092019/properties/PR2195046335334fed919db3fcdbeb3c2b/publishing/LB8d750f8e1c1c4210a75b9e9b0b494e44",
  "networkResponse": {
    "headers": {
      "cache-control": "no-cache",
      "content-type": "application/vnd.api+json"
    },
    "status": 409,
    "statusText": "Conflict",
    "type": "cors",
    "url": "https://reactor.adobe.io/libraries/LB8d750f8e1c1c4210a75b9e9b0b494e44",
    "textBody": "{\"errors\":[{\"id\":\"edf0d5b9-2739-4ae2-9a92-38f010b2575e\",\"code\":\"invalid-status\",\"title\":\"Invalid status\",\"detail\":\"cannot create a library with an environment having the failed status\",\"meta\":{\"request_id\":\"GLRikvzNKrcnKCXKUOyaJjkBEGUYFrdc\"},\"source\":{\"pointer\":\"/data/attributes/status\"}}]}",
    "body": {
      "errors": [
        {
          "id": "edf0d5b9-2739-4ae2-9a92-38f010b2575e",
          "code": "invalid-status",
          "title": "Invalid status",
          "detail": "cannot create a library with an environment having the failed status",
          "meta": {
            "request_id": "GLRikvzNKrcnKCXKUOyaJjkBEGUYFrdc"
          },
          "source": {
            "pointer": "/data/attributes/status"
          }
        }
      ]
    }
  }
}

 

Account information at time of report:
    Organization: SWINBURNE UNIVERSITY OF TECHNOLOGY (C73C15F354EA1C420A4C98A4@AdobeOrg)
    Company: SWINBURNE UNIVERSITY OF TECHNOLOGY (COca49f01decef444a8eaa09d707092019)
    Property: Swinburne Server Side (PR2195046335334fed919db3fcdbeb3c2b)
    IMS User: Paul Broomfield (67CA56935FB5E0650A495C48@AdobeID)

 

Avatar

Correct answer by
Employee

Hi Paul,

You can see from the error that the core of the issue is the environment you're adding to the library had a failed status.  This should now be resolved for your property. 

Avatar

Employee

Hey,  we have reviewed this error and have resolved the issue for your property,   if you try again it should work for you.