Highlighted

Library building very slow

Avatar

Avatar

Olivier_Blonste

Avatar

Olivier_Blonste

Olivier_Blonste

27-02-2019

Is there anything I could be doing that makes the Launch library building so slow, up to 3 minutes?

I only have 3 extensions (including Core), 33 rules and 14 data elements.

Thanks,

Olivier

Replies

Highlighted

Avatar

Avatar

Andrey_Osadchuk

MVP

Avatar

Andrey_Osadchuk

MVP

Andrey_Osadchuk
MVP

28-02-2019

Hi Olivier,

There is one trick. While the library is being built switch between different tabs (e.g. Rules > Publishing > Rules). Usually, this helps to have the library marked as ready much faster. Let me know if that works for you?

Highlighted

Avatar

Avatar

olivierb2475170

Avatar

olivierb2475170

olivierb2475170

28-02-2019

Hi Andrey,

Thank you very much for your answer. So if I understand correctly, the library gets built relatively quickly but it's the notification of the "library built" that is slow to get displayed?

I built the library several times very early this morning (Eastern timezone) and it was way much faster than when I do it in the afternoon. I guess the speed is also a function of how many concurrent users are building libraries.

Thanks again for your answer, I'll check your trick this afternoon.

Best,

Olivier

Highlighted

Avatar

Avatar

marschrode

Avatar

marschrode

marschrode

17-07-2019

Same here. But much much longer. Building a super simple lib with just two rules and 3 dataElements and 2 Libraries can take up to 20 minutes.... 20 MINUTES !!!!