Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Launch Header and Footer code Setup

Vijaya_Vignesha
Level 1
Level 1

I am trying to set up Launch Header and Footer Script, I am unable to see any image request send to Adobe. I can see from console the libraries are loading properly, is this an Expected Behavior? Do i need to set up rules for Triggering Image request(But in DTM Only Header and Footer scripts will give Image beacon)

Thanks in Advance,

Vijayavigneshan.

1 Accepted Solution
joshd7227840
Correct answer by
Community Advisor
Community Advisor

Without seeing your config, my first guess is that you have not setup a rule to fire Adobe Analytics (AA).  With DTM, when you setup AA as a tool, it will automatically trigger on page load without setting up any rules.  But in Launch, the opposite is the case: by default it will not trigger, so you need to setup a rule to trigger it.  If you have not done this, then see instructions below. If you have done this already and still do not see an AA request, then you need to provide more details (a link to a test page would also be really helpful)

Implementing a Rule for Adobe Analytics page view.

Go to Rules tab, and click Add Rule.

Under EVENTS, click +Add.

For Extension, choose Core

For Event Type, scroll down the dropdown section and choose something from the PAGE LOAD section.  Most common choices are Page Bottom or DOM Ready, but which one works best for you depends on your overall implementation needs.

Click Keep Changes to save the Event Configuration.

Under the THEN section, under ACTIONS, click +Add.

In the left nav area, under Action Configuration , under Extension, select Adobe Analytics.

Under Action Type, select Send Beacon.

To the right, under Tracking, select s.t() (default selected).

Click Keep Changes to save the Action Configuration.

Then, click Save (or if you selected a Dev Library, click Save to Library and Build).

Finally, you will need to then add to a library and build (Publishing tab) for changes to show up.

View solution in original post

1 Reply
joshd7227840
Correct answer by
Community Advisor
Community Advisor

Without seeing your config, my first guess is that you have not setup a rule to fire Adobe Analytics (AA).  With DTM, when you setup AA as a tool, it will automatically trigger on page load without setting up any rules.  But in Launch, the opposite is the case: by default it will not trigger, so you need to setup a rule to trigger it.  If you have not done this, then see instructions below. If you have done this already and still do not see an AA request, then you need to provide more details (a link to a test page would also be really helpful)

Implementing a Rule for Adobe Analytics page view.

Go to Rules tab, and click Add Rule.

Under EVENTS, click +Add.

For Extension, choose Core

For Event Type, scroll down the dropdown section and choose something from the PAGE LOAD section.  Most common choices are Page Bottom or DOM Ready, but which one works best for you depends on your overall implementation needs.

Click Keep Changes to save the Event Configuration.

Under the THEN section, under ACTIONS, click +Add.

In the left nav area, under Action Configuration , under Extension, select Adobe Analytics.

Under Action Type, select Send Beacon.

To the right, under Tracking, select s.t() (default selected).

Click Keep Changes to save the Action Configuration.

Then, click Save (or if you selected a Dev Library, click Save to Library and Build).

Finally, you will need to then add to a library and build (Publishing tab) for changes to show up.

View solution in original post