Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Event firing more often in Launch than DTM

philipk92120636
Level 4
Level 4

Hi everyone!

We've migrated from DTM to Launch.

We have some legacy page view events in our custom code that fire both the hit and visit based variant of the event when a customer visits a specific page:

 

 

if (pageName == "section|subsection1|subsection2|title") {
s.events = s.events ? s.events += ',' + 'event1,event2' : 'event1,event2';
}

 

 

The hit based variant of the event tracked against the page views metric in Analytics exactly when deploying with DTM, but since migrating to Launch the event metric exceeds the page views metric by about 50%. After firing the event I'm using the 'Clear Variables' action to reset the event string and when debugging I can't see multiple instances of the same event.

Does Launch process or send events differently? Is there something I need to tweak in the configuration?

Analytics events launch
1 Accepted Solution
Andrey_Osadchuk
Correct answer by
Community Advisor
Community Advisor

Philip,

What I would advise to start with is to optimize the code the way that event1 and event2 are appended through the s.apl() plugin to prevent events duplication in case they are set somewhere else (in other rules, for example).

Ideally, share the website URL and scenario where that is happening. I am sure we will find an issue in the code. Alternatively, share the library URL and I will help you debug the Launch implementation via Launch Inspector.

View solution in original post

14 Replies
Charles_Thirupathi
Level 3
Level 3
Hi Philip, Can you share URL to debug further? Is the above shared code is placed inside do plugin function?
philipk92120636
Level 4
Level 4
Hi Charles. This code is not in doPlugins, it's just added to the custom code in the 'Set Variables' action in the page load rule. Regarding the URL, are you based in the UK as our site isn't properly available internationally?
Charles_Thirupathi
Level 3
Level 3
Hi Philip, I'm located in India just share the URL let me try if the page gets loaded then i can able to debug
franzli
Level 4
Level 4

If you don't mind sharing the URL I can take a look as well. You can reach out to me via DM or find me on measure slack (Francis Li)

philipk92120636
Level 4
Level 4
Hi Charles and Francis. I'll DM you guys the URL
jantzen_belliston-Adobe
Community Manager
Community Manager
Were you able to solve this issue? If so, would you mind posting the solution so others that find this thread have the answer?
Andrey_Osadchuk
Correct answer by
Community Advisor
Community Advisor

Philip,

What I would advise to start with is to optimize the code the way that event1 and event2 are appended through the s.apl() plugin to prevent events duplication in case they are set somewhere else (in other rules, for example).

Ideally, share the website URL and scenario where that is happening. I am sure we will find an issue in the code. Alternatively, share the library URL and I will help you debug the Launch implementation via Launch Inspector.

View solution in original post

Andrey_Osadchuk
Community Advisor
Community Advisor
BTW, also, try to break down the events by custom link, exit link and download link. This will help to partly check if the events are reset or not after the beacon is sent.
philipk92120636
Level 4
Level 4
Hi Andrey. Thanks for the response. In the interim I decided to turn off the events on the live site. However, it looks like it's linked to a wider issue we're having following our migration which I've detailed here: https://experienceleaguecommunities.adobe.com/t5/adobe-experience-platform-launch/inflated-page-name...
AndrewWathen
Community Advisor
Community Advisor
@philipk92120636 Happy to have a look if you DM me the URL. Also, have you had a look in Workspace to see what the additional events are coming through against? Is it setting the event more than once against a single page view, or are the additional events originating from link tracking metrics calls?
philipk92120636
Level 4
Level 4
The event itself was linked to our page load rule. It just fired the success event if the page was the specified page name. I had to turn off the events in our production environment. I'll have a look at the historical data as you've suggested.