Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Event Enters Viewport does not work

Avatar

Level 4

Hi all,

I have tried the "Enters Viewport" event in a couple of projects now and it never works for me. All of the projects are SPAs, nevertheless, I would assume that the event is bind to window scroll as well, so there should be no difference between SPAs and common websites.

Here is a screenshot of what I'm configuring. Maybe I'm doing something wrong. Anyone else experiencing problems with this event type?

1544246_pastedImage_0.png

Thanks for your help!

Best,

Konstantin

3 Replies

Avatar

Level 10

How are you determining that the rule isn't working? Are you just not seeing a beacon? Have you turned on the debugger mode and looked to see which rules are firing?

Avatar

Level 4

Hi Jantzen.Belliston, thanks for your answer. I tried:

  1. Console.log as action => no console log
  2. Send beacon as action => no beacon send (Omnibug, network traffic, and console don't show anything)
  3. Debugging mode => rule name never shows up in the console, although the Item is visible

I also double checked the css-selector and it exists on the page. Even changing the selector to something very stupid like "div" did make the difference, the rule never fired.

Avatar

Level 10

Thanks for the detailed response. Is the URL publicly available by chance? It would be great if the community members could replicate the issue and troubleshoot the page directly.