checking rule in built library not updated

joew68937582

30-07-2018

From the Publishing tab, when I click on a built library to view its contents, then click a Rule to verify that changes to the rule are present in the build I get an out of date view of the rule on this Edit Rule screen. Here are some notes I took on what I ran into and how I eventually worked around it;

July 30

- Rules tab, Adobe Target says it was last modified Mar 26, this is wrong, an action in this rule was modified last week.

Open the "Adobe Target" rule and the actions contain the latest updates (Actions, note the order: "Adobe Target - Add Params to Global Mbox" > "Load Adobe Target" > "Adobe Target - Fire Global Mbox"), despite not having changed anything I Keep Changes and Save. Last Modified remains unchanged. 😕

On Publishing tab, latest published library was published Jul 25. If I view its contents it shows the Actions in the wrong order ("Load Adobe Target" > "Adobe Target - Add Params to Global Mbox" > "Adobe Target - Fire Global Mbox"), I don't believe this is what is actually published.

Return to Publishing tab, without a Working Library selected.

Click + to add library. Give it a name, select an environment. Click "Add a Resource", and select Rules > Adobe Target > Latest > Select & Create a New Revision (note, on this screen it says it was last modified Mar 26, again wrong), Save & Build for Development.

The library builds, and then I check the "Adobe Target" rule in the library, and actions are "Load Adobe Target" > "Adobe Target - Add Params to Global Mbox" > "Adobe Target - Fire Global Mbox"; this is incorrect. However, the "...Add Params..." action does contain last week's change, so it might just be that the Edit Rule screen is showing the wrong thing.

I find this to be highly misleading and damaging to my confidence in the tool.

So, I wonder if the Edit Rule screen, when accessed from a built library has a problem because the change that was made last week was a change to an action, not directly to the rule. To test this I change the rule's order of actions, save the rule, then change it back and save that. Despite directly editing the rule the Last Modified date is still Mar 26. However, now when I access the rule from the built library it presents the actions in the correct order.

This gives me enough confidence to publish the library, but this behavior needs to be corrected so that the contents of a library, including the attributes of the included rules can be inspected.

Comment