Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Cannot deploy at.js code 2.0 over Adobe Launch

KRAZ
Level 4
Level 4

Hi all,

I've been trying for several days now to get the at.js 2.0 running for SPAs, until I finally found the documentation​. Now that I got it to work using the adobe.target.getOffers() & adobe.target.applyOffers() function I cannot insert the code over Launch because the editor shows an error and the minifying of custom code fails. See screenshots below. Any ideas how this will work out?

Editor:

1707109_pastedImage_3.png

Build:

1707110_pastedImage_5.png

1 Accepted Solution
KRAZ
Correct answer by
Level 4
Level 4

Okay I found the solution in the documentation of .then().

Here is the rewritten code:

adobe.target.getOffers({

  request: {

    "prefetch": {

      "views": [{}]

    }

  }

})

.then( function(response) { adobe.target.applyOffers({ response: response }); })

.then( function() { console.log("Success"); })

.catch( function(error) { console.log("Error", error)});

View solution in original post

1 Reply
KRAZ
Correct answer by
Level 4
Level 4

Okay I found the solution in the documentation of .then().

Here is the rewritten code:

adobe.target.getOffers({

  request: {

    "prefetch": {

      "views": [{}]

    }

  }

})

.then( function(response) { adobe.target.applyOffers({ response: response }); })

.then( function() { console.log("Success"); })

.catch( function(error) { console.log("Error", error)});

View solution in original post