Highlighted

Cannot bulk save&build for dev

weizhenm5308321

04-09-2018

Hi,

We are migrating our DTM setup to Launch at the moment, when tons of rules (150) are being recreated in Launch manually.

Since it is inefficient to click on Save and Build button and wait for build process done every time a rule is configured, we click only Save button then bulk save&build on Publishing screen. This has been working pretty well until now.

Today when we tried to Save&build on publishing screen of dev environment, the button turns grey and stuck there without any more message, there is no spinning loading icon, just completely silent and unclickable grey save&build button.

When I checked in browser console, I can see many requests are made to https://mc-api-activation-reactor.adobe.io/rules  endpoint first with 204 status code then turn into 200 after reponse is received. While there are also many warning message in console:

client.js:1800 The "quiet" variant of Button is deprecated. Please use the quiet "primary" variant instead.

client.js:1800 The "minimal" variant of Button is deprecated. Please use the quiet "secondary" variant instead.

Also tested with Save&Build for single rule each time, which works just fine. We may have changed global setting of Adobe Analytics, so we really need the bulk function to build all rules. Please help asap thanks!

P.S I checked Launch Bug - Unable to Save and Build Library , it doesnt seem like the same issue, as single save and build works for me.

/Weizhen

Replies

Highlighted

stevew79063868

05-09-2018

I have this same issue.

Save&Build works fine on individual rules or data elements, but the button just goes grey when doing it from the Edit Library part of the Publishing interface.

Edit: Just found this Launch Bug - Unable to Save and Build Library  and the solution there worked

Highlighted

Gigazelle

Employee

13-09-2018

Hi Weizhen, I don't know if we'll be able to definitively provide an answer without directly looking at the implementation.

If you can have a customer support delegate create a ticket with customer care and provide information on when/where the save/build button is greyed out, we can check it out and potentially provide a fix there.