Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

add new folder issue

josieqqiu
Level 3
Level 3

hi @Jörg_Hoh 

we have a project added a new folder, and make a new package to install at new server, but we find after finish install we just can see the path structure, but every path cannot render content.  meanwhile if we copy the content to any new path that create by author server (http://localhost:4503/siteadmin#/content), every path can render at author server! 

so we unzip the package find the .content.xml under the new path in the content install package  is 


<?xml version="1.0" encoding="UTF-8"?>
<jcr:root xmlns:cq="http://www.day.com/jcr/cq/1.0" xmlns:jcr="http://www.jcp.org/jcr/1.0"
jcr:primaryType="cq:Page">
<xxx/>
</jcr:root>

 

seems miss something, usually cq:Page may have a jcr:content node ,but this file have not, may I know  must add jcr:content node when  jcr:primaryType="cq:Page"?

thank you!!!

 

5 Replies
josieqqiu
Level 3
Level 3
in fact when we add a content node to that file, and install it , every path can render at author server . but we just confuse why no content node every page under xxx cannot render?
josieqqiu
Level 3
Level 3
may I know when your team can help to check this question?
Jörg_Hoh
Employee
Employee
@josieqqiu: As mentioned by @yuhisg please re-post the question in the AEM forum