Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

WKND tutorial core components package not compatible with AEM 6.5

Avatar

Level 1

I used the latest archetype for the WKND component (version=35).

This uses newer version of wcm.components.core (2.17.12), unlike my AEM instance which uses lower version of wcm.components.core (2.3.2).

When, generating and installing with maven, there is an error for the api bundle: com.day.cq.wcm.api,version=[1.28,2) -- Cannot be resolved

From here, the "en.html" page is empty and no components are available to insert. This is because of another error which states:

com.adobe.cq.wcm.core.components.models.Page cannot be resolved to a type

Does anyone have a solution to this? 

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

Hi @Ginovski, to solve the issue you need to pick up one of below solutions:

  1. Upgrade your AEM instance by installing Service Pack 7 or higher, this is according to system requirements for archetype version 35 - https://github.com/adobe/aem-project-archetype#system-requirements
    You can download service packs from software distribution service https://experience.adobe.com/#/downloads/content/software-distribution/en/aem.html
  2. Generate your project using older version of archetype, you can find detailed compatibility matrix that is presenting which archetype version supports which AEM version under this link https://github.com/adobe/aem-project-archetype/blob/develop/VERSIONS.md
  3. Last option is to manually change version of core components you are using in your project according to following document https://experienceleague.adobe.com/docs/experience-manager-core-components/using/versions.html?lang=..., please keep in mind that changing the version number could not be enough and maybe you will need to align version of other dependencies as well.

View solution in original post

1 Reply

Avatar

Correct answer by
Community Advisor

Hi @Ginovski, to solve the issue you need to pick up one of below solutions:

  1. Upgrade your AEM instance by installing Service Pack 7 or higher, this is according to system requirements for archetype version 35 - https://github.com/adobe/aem-project-archetype#system-requirements
    You can download service packs from software distribution service https://experience.adobe.com/#/downloads/content/software-distribution/en/aem.html
  2. Generate your project using older version of archetype, you can find detailed compatibility matrix that is presenting which archetype version supports which AEM version under this link https://github.com/adobe/aem-project-archetype/blob/develop/VERSIONS.md
  3. Last option is to manually change version of core components you are using in your project according to following document https://experienceleague.adobe.com/docs/experience-manager-core-components/using/versions.html?lang=..., please keep in mind that changing the version number could not be enough and maybe you will need to align version of other dependencies as well.

Avatar

Community Advisor

Hi @Ginovski 

 

You need to install the latest service pack on your AEM 6.5 instance. As of today the latest Service Pack available is AEM 6.5.11.0 [1].

 

Download and install the latest service pack and it should resolve the issue with Archetype 35. After that all the pages will render perfectly fine!

 

[1]. https://experienceleague.adobe.com/docs/experience-manager-65/release-notes/release-notes.html

 

Thanks!